aboutsummaryrefslogtreecommitdiff
path: root/net-misc/gnunet/gnunet-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/gnunet/gnunet-9999.ebuild')
-rw-r--r--net-misc/gnunet/gnunet-9999.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/net-misc/gnunet/gnunet-9999.ebuild b/net-misc/gnunet/gnunet-9999.ebuild
index 282fab7..d705cf1 100644
--- a/net-misc/gnunet/gnunet-9999.ebuild
+++ b/net-misc/gnunet/gnunet-9999.ebuild
@@ -34,16 +34,12 @@ case ${PV} in
34"9999") 34"9999")
35 inherit autotools git-r3 user python-any-r1 flag-o-matic 35 inherit autotools git-r3 user python-any-r1 flag-o-matic
36 # using latest git. caution: 36 # using latest git. caution:
37 # this methode is prone to man-in-the-middle attacks 37 # this method is prone to man-in-the-middle attacks
38 ;; 38 ;;
39"0.10.2_rc3") 39"0.10.2_rc4")
40 inherit autotools git-r3 user python-any-r1 flag-o-matic 40 inherit autotools git-r3 user python-any-r1 flag-o-matic
41 EGIT_COMMIT="c87a389a4f842c20383d8619120b188e104cf64a" 41 EGIT_COMMIT="6bcc73a1cbb1d4a609884762eab1b6de761ad1d9"
42 ;; 42 ;;
43"0.10.2_rc2")
44 inherit autotools git-r3 user python-any-r1 flag-o-matic
45 EGIT_COMMIT="922318150433906dafd11adb5185a6ff664573db"
46 ;;
47"0.10.1") 43"0.10.1")
48 inherit autotools user python-any-r1 flag-o-matic 44 inherit autotools user python-any-r1 flag-o-matic
49 SRC_URI="mirror://gnu/${PN}/${P}.tar.gz" 45 SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
@@ -94,7 +90,10 @@ RDEPEND="
94 sys-libs/zlib 90 sys-libs/zlib
95 httpd? ( >=net-libs/libmicrohttpd-0.9.42[messages] ) 91 httpd? ( >=net-libs/libmicrohttpd-0.9.42[messages] )
96 nls? ( >=sys-devel/gettext-0.18.1 ) 92 nls? ( >=sys-devel/gettext-0.18.1 )
97 nss? ( dev-libs/nss ) 93 nss? (
94 dev-libs/nss
95 sys-libs/glibc
96 )
98 dev-libs/gmp:0= 97 dev-libs/gmp:0=
99 X? ( 98 X? (
100 x11-libs/libXt 99 x11-libs/libXt
@@ -167,7 +166,7 @@ src_configure() {
167 $(use_enable experimental ) \ 166 $(use_enable experimental ) \
168 $(use_with httpd microhttpd ) \ 167 $(use_with httpd microhttpd ) \
169 $(use_with mysql ) \ 168 $(use_with mysql ) \
170 $(use_with postgres ) \ 169 $(use_with postgres postgresql ) \
171 $(use_with sqlite ) \ 170 $(use_with sqlite ) \
172 $(use_with X x ) \ 171 $(use_with X x ) \
173 $(use_with gnutls ) \ 172 $(use_with gnutls ) \
@@ -177,8 +176,13 @@ src_configure() {
177 176
178 177
179src_install() { 178src_install() {
179 into /
180 use nss && dolib.so src/gns/nss/.libs/libnss_gns*.so*
180 emake DESTDIR="${D}" install 181 emake DESTDIR="${D}" install
182 rm -rf ${D}/usr/lib/gnunet/nss
181 newinitd "${FILESDIR}/${PN}.initd" gnunet 183 newinitd "${FILESDIR}/${PN}.initd" gnunet
184 insinto /etc
185 use nss && doins "${FILESDIR}/nsswitch.conf"
182 insinto /etc/gnunet 186 insinto /etc/gnunet
183 doins "${FILESDIR}/gnunet.conf" 187 doins "${FILESDIR}/gnunet.conf"
184 keepdir /var/{lib,log}/gnunet 188 keepdir /var/{lib,log}/gnunet
@@ -188,7 +192,8 @@ src_install() {
188pkg_postinst() { 192pkg_postinst() {
189 # We should update the gtk icon cache for the icons. 193 # We should update the gtk icon cache for the icons.
190 # @TODO: provide average working example config to copy for user. 194 # @TODO: provide average working example config to copy for user.
191 # @TOO: point out that exact time is needed currently. 195 # @TODO: point out that exact time is needed currently.
196 elog " "
192 elog "To configure" 197 elog "To configure"
193 elog " 1) Add desired user(s) to the 'gnunet' group" 198 elog " 1) Add desired user(s) to the 'gnunet' group"
194 elog " 2) Edit the system-wide config file '/etc/gnunet/gnunet.conf'" 199 elog " 2) Edit the system-wide config file '/etc/gnunet/gnunet.conf'"