aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 15 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 38173aa..329e771 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,14 +19,14 @@
19# 19#
20# Process this file with autoconf to produce a configure script. 20# Process this file with autoconf to produce a configure script.
21# 21#
22AC_PREREQ(2.61) 22AC_PREREQ([2.71])
23AC_INIT([gnunet-ext],[0.0.0],[bug-gnunet@gnu.org]) 23AC_INIT([gnunet-ext],[0.0.0],[bug-gnunet@gnu.org])
24AM_INIT_AUTOMAKE([tar-ustar]) 24AM_INIT_AUTOMAKE([tar-ustar])
25AM_CONFIG_HEADER(gnunet_ext_config.h) 25AM_CONFIG_HEADER(gnunet_ext_config.h)
26 26
27AH_TOP([#define _GNU_SOURCE 1]) 27AH_TOP([#define _GNU_SOURCE 1])
28 28
29AC_ISC_POSIX 29AC_SEARCH_LIBS([strerror],[cposix])
30AC_PROG_AWK 30AC_PROG_AWK
31AC_PROG_CC 31AC_PROG_CC
32AC_PROG_MKDIR_P 32AC_PROG_MKDIR_P
@@ -34,15 +34,23 @@ AC_PROG_CPP
34AC_PROG_INSTALL 34AC_PROG_INSTALL
35AC_PROG_LN_S 35AC_PROG_LN_S
36AC_PROG_MAKE_SET 36AC_PROG_MAKE_SET
37AC_LIBTOOL_WIN32_DLL 37
38AC_PROG_CC 38AC_PROG_CC
39AM_PROG_CC_STDC 39AM_PROG_CC_STDC
40AC_HEADER_STDC 40m4_warn([obsolete],
41[The preprocessor macro `STDC_HEADERS' is obsolete.
42 Except in unusual embedded environments, you can safely include all
43 ISO C90 headers unconditionally.])dnl
44# Autoupdate added the next two lines to ensure that your configure
45# script's behavior did not change. They are probably safe to remove.
46AC_CHECK_INCLUDES_DEFAULT
47AC_PROG_EGREP
48
41AC_CANONICAL_HOST 49AC_CANONICAL_HOST
42 50
43# dynamic libraries/plugins 51# dynamic libraries/plugins
44AC_DISABLE_STATIC 52AC_DISABLE_STATIC
45AC_PROG_LIBTOOL 53LT_INIT([disable-static dlopen])
46 54
47AC_SYS_LARGEFILE 55AC_SYS_LARGEFILE
48AC_FUNC_FSEEKO 56AC_FUNC_FSEEKO
@@ -199,10 +207,11 @@ AC_DEFINE_DIR([PACKAGE_DATA], [datarootdir], [The directory for installing read-
199packagesrcdir=`cd $srcdir && pwd` 207packagesrcdir=`cd $srcdir && pwd`
200AC_DEFINE_UNQUOTED(PACKAGE_SOURCE_DIR, "${packagesrcdir}", [source dir]) 208AC_DEFINE_UNQUOTED(PACKAGE_SOURCE_DIR, "${packagesrcdir}", [source dir])
201 209
202AC_OUTPUT([ po/Makefile.in 210AC_CONFIG_FILES([ po/Makefile.in
203Makefile 211Makefile
204src/Makefile 212src/Makefile
205src/include/Makefile 213src/include/Makefile
206src/ext/Makefile 214src/ext/Makefile
207src/ext/ext.conf 215src/ext/ext.conf
208]) 216])
217AC_OUTPUT