aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-06-03 15:07:49 +0000
committerChristian Grothoff <christian@grothoff.org>2012-06-03 15:07:49 +0000
commitd77cf8f3c06ef1673167cac22f5f1072c8eb3584 (patch)
tree5212b62147b416ca33541d085f500f91d32427e8 /configure.ac
parentaced3911edbe1c1605fbca574d47091784d4939b (diff)
downloadgnunet-fuse-d77cf8f3c06ef1673167cac22f5f1072c8eb3584.tar.gz
gnunet-fuse-d77cf8f3c06ef1673167cac22f5f1072c8eb3584.zip
-fixing build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 7 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index d0cf129..d5c6e41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of GNUnet. 1# This file is part of GNUnet.
2# (C) 2001-2011 Christian Grothoff (and other contributing authors) 2# (C) 2001-2012 Christian Grothoff (and other contributing authors)
3# 3#
4# GNUnet is free software; you can redistribute it and/or modify 4# GNUnet is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published 5# it under the terms of the GNU General Public License as published
@@ -20,9 +20,9 @@
20# Process this file with autoconf to produce a configure script. 20# Process this file with autoconf to produce a configure script.
21# 21#
22AC_PREREQ(2.61) 22AC_PREREQ(2.61)
23AC_INIT([gnunet-ext],[0.0.0],[bug-gnunet@gnu.org]) 23AC_INIT([gnunet-fuse],[0.9.3],[bug-gnunet@gnu.org])
24AM_INIT_AUTOMAKE([gnunet-ext], [0.0.0]) 24AM_INIT_AUTOMAKE([gnunet-fuse], [0.9.3])
25AM_CONFIG_HEADER(gnunet_ext_config.h) 25AM_CONFIG_HEADER(gnunet_fuse_config.h)
26 26
27AH_TOP([#define _GNU_SOURCE 1]) 27AH_TOP([#define _GNU_SOURCE 1])
28 28
@@ -35,18 +35,13 @@ AC_PROG_CPP
35AC_PROG_INSTALL 35AC_PROG_INSTALL
36AC_PROG_LN_S 36AC_PROG_LN_S
37AC_PROG_MAKE_SET 37AC_PROG_MAKE_SET
38AC_LIBTOOL_WIN32_DLL
39AC_PROG_CC 38AC_PROG_CC
40AM_PROG_CC_STDC 39AM_PROG_CC_STDC
41AC_HEADER_STDC 40AC_HEADER_STDC
42AC_CANONICAL_HOST 41AC_CANONICAL_HOST
43
44# dynamic libraries/plugins
45AC_DISABLE_STATIC
46AC_PROG_LIBTOOL
47
48AC_SYS_LARGEFILE 42AC_SYS_LARGEFILE
49AC_FUNC_FSEEKO 43AC_FUNC_FSEEKO
44AM_PROG_CC_C_O
50 45
51CFLAGS="-Wall $CFLAGS" 46CFLAGS="-Wall $CFLAGS"
52# use '-fno-strict-aliasing', but only if the compiler can take it 47# use '-fno-strict-aliasing', but only if the compiler can take it
@@ -168,7 +163,7 @@ fi
168 163
169if test "x$gnunet" == "x0" 164if test "x$gnunet" == "x0"
170then 165then
171 AC_MSG_ERROR([gnunet-gtk requires GNUnet]) 166 AC_MSG_ERROR([gnunet-fuse requires GNUnet])
172fi 167fi
173 168
174AC_SUBST(GNUNET_CFLAGS) 169AC_SUBST(GNUNET_CFLAGS)
@@ -187,5 +182,5 @@ AC_OUTPUT([ po/Makefile.in
187Makefile 182Makefile
188src/Makefile 183src/Makefile
189src/include/Makefile 184src/include/Makefile
190src/ext/Makefile 185src/fuse/Makefile
191]) 186])