aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-07 14:35:42 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-07 14:35:42 +0000
commit484400497834e7d0b2b1c3696441b6728b17c2f4 (patch)
tree290f2f3ebf99f0efe6291de44f5a56a76105c7df /configure.ac
parente2ebf3bcc24c93e78333d8845224d9bfc33564ec (diff)
downloadgnunet-gtk-484400497834e7d0b2b1c3696441b6728b17c2f4.tar.gz
gnunet-gtk-484400497834e7d0b2b1c3696441b6728b17c2f4.zip
splitting of gnunet-namestore-gtk from gnunet-setup, see #3054
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 8119a282..ed5fd39c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of GNUnet. 1# This file is part of GNUnet.
2# (C) 2001--2012 Christian Grothoff (and other contributing authors) 2# (C) 2001--2013 Christian Grothoff (and other contributing authors)
3# 3#
4# GNUnet is free software; you can redistribute it and/or modify 4# GNUnet is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published 5# it under the terms of the GNU General Public License as published
@@ -173,7 +173,7 @@ AC_ARG_WITH(extractor,
173 ], 173 ],
174 [AC_MSG_RESULT([--with-extractor not specified]) 174 [AC_MSG_RESULT([--with-extractor not specified])
175 AC_CHECK_HEADERS(extractor.h,extractor=1)]) 175 AC_CHECK_HEADERS(extractor.h,extractor=1)])
176if test "$extractor" != 1 176if test "$extractor" != 1
177then 177then
178 AC_MSG_ERROR([gnunet-gtk requires libextractor headers]) 178 AC_MSG_ERROR([gnunet-gtk requires libextractor headers])
179fi 179fi
@@ -181,7 +181,7 @@ fi
181 181
182# test for libqrencode 182# test for libqrencode
183qrencode=0 183qrencode=0
184QR_LIBS="-lqrencode" 184QR_LIBS="-lqrencode"
185AC_MSG_CHECKING(for libqrencode) 185AC_MSG_CHECKING(for libqrencode)
186AC_ARG_WITH(qrencode, 186AC_ARG_WITH(qrencode,
187 [ --with-qrencode=PFX Base of libqrencode installation], 187 [ --with-qrencode=PFX Base of libqrencode installation],
@@ -203,7 +203,7 @@ AC_ARG_WITH(qrencode,
203 [AC_MSG_RESULT([--with-qrencode not specified]) 203 [AC_MSG_RESULT([--with-qrencode not specified])
204 AC_CHECK_HEADERS(qrencode.h,qrencode=1)]) 204 AC_CHECK_HEADERS(qrencode.h,qrencode=1)])
205 205
206if test "$qrencode" != 1 206if test "$qrencode" != 1
207then 207then
208QR_LIBS="" 208QR_LIBS=""
209QR_CFLAGS="" 209QR_CFLAGS=""
@@ -244,7 +244,7 @@ then
244 have_libunique=no 244 have_libunique=no
245 if test x$with_libunique != xno; then 245 if test x$with_libunique != xno; then
246 PKG_CHECK_MODULES([unique], [unique-3.0], AC_DEFINE(HAVE_LIBUNIQUE, 1, [Define if libunique is available]), AC_MSG_WARN([libunique would be nice to have])) 246 PKG_CHECK_MODULES([unique], [unique-3.0], AC_DEFINE(HAVE_LIBUNIQUE, 1, [Define if libunique is available]), AC_MSG_WARN([libunique would be nice to have]))
247 fi 247 fi
248fi 248fi
249 249
250if test "x$without_gtk" == "xfalse" -a "x$check_for_2" != "xfalse" 250if test "x$without_gtk" == "xfalse" -a "x$check_for_2" != "xfalse"
@@ -514,6 +514,7 @@ src/fs/Makefile
514src/fs/gnunet-fs-gtk.conf 514src/fs/gnunet-fs-gtk.conf
515src/identity/Makefile 515src/identity/Makefile
516src/peerinfo/Makefile 516src/peerinfo/Makefile
517src/namestore/Makefile
517src/setup/Makefile 518src/setup/Makefile
518src/statistics/Makefile 519src/statistics/Makefile
519pixmaps/Makefile 520pixmaps/Makefile
@@ -524,11 +525,12 @@ gnunet-setup.desktop
524contrib/gnunet_fs_gtk_about_window.glade 525contrib/gnunet_fs_gtk_about_window.glade
525contrib/gnunet_identity_gtk_about_window.glade 526contrib/gnunet_identity_gtk_about_window.glade
526contrib/gnunet_peerinfo_gtk_about_window.glade 527contrib/gnunet_peerinfo_gtk_about_window.glade
528contrib/gnunet_namestore_gtk_about_window.glade
527contrib/gnunet_statistics_gtk_about_window.glade 529contrib/gnunet_statistics_gtk_about_window.glade
528contrib/gnunet_setup_about_window.glade 530contrib/gnunet_setup_about_window.glade
529]) 531])
530 532
531if test "$qrencode" != 1 533if test "$qrencode" != 1
532then 534then
533 AC_MSG_WARN([gnunet-setup will not include QR support]) 535 AC_MSG_WARN([gnunet-setup will not include QR support])
534fi 536fi