aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
authorLRN <lrn1986@gmail.com>2013-03-03 01:58:05 +0000
committerLRN <lrn1986@gmail.com>2013-03-03 01:58:05 +0000
commitf4c67987e48202648c7621dd8c9057bd8174d0d5 (patch)
tree11336eff3aa38971e2342f2e876477dd5fd69486 /src/fs/Makefile.am
parentcb415c04aac4a8ba95bc40475708ad4b2869a3c8 (diff)
downloadgnunet-gtk-f4c67987e48202648c7621dd8c9057bd8174d0d5.tar.gz
gnunet-gtk-f4c67987e48202648c7621dd8c9057bd8174d0d5.zip
Massive namespace UI update
New Namespace Organizer dialog (replaces the "Create namespace" dialog, also allows namespace deletion and renaming). Allows user to select which namespace to use for publications. Main Window menu was changed appropriately. Glade-3.8 removed use_action_appearance=False eveywhere. Glade-3.8 removed all treeview selection objects. Publication master dialog now uses selected default namespace (if any) only. Added frames to Pubdialog VPaned to make it more obvious, as per GTK docs. Replaced pseudonym-selection treeview with an identifier-selection treeview. Reworked the look of identifiers graph. IDs in italics point at looping points. IDs in bold are graph endpoints (recommended IDs). More precise loop detection (more data is hashed). Removed the hashmap-related fixme. Hash collisions will add some duplicate nodes into the tree. Acceptable. Fixed names of some auxiliary objects (size groups, images). Removed adjustments (use the defaults). Moved some code into GNUNET_FS_GTK_advertise_namespace() function, made it shared. Fixed a bug in main window namespace selector ("selected-row-reference" does not exist anymore). Fixed a bug in OpenURI dialog (correct anonymity widget name). TODO: insert NS advertisements into KBlocks when both global and private namespace publication is enabled.
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 9bfa0db6..6ea4a604 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -14,6 +14,7 @@ gnunet_fs_gtk_SOURCES = \
14 gnunet-fs-gtk.c gnunet-fs-gtk.h \ 14 gnunet-fs-gtk.c gnunet-fs-gtk.h \
15 gnunet-fs-gtk_about.c \ 15 gnunet-fs-gtk_about.c \
16 gnunet-fs-gtk_advertise-pseudonym.c \ 16 gnunet-fs-gtk_advertise-pseudonym.c \
17 gnunet-fs-gtk_advertise-pseudonym.h \
17 gnunet-fs-gtk_anonymity-widgets.c gnunet-fs-gtk_anonymity-widgets.h \ 18 gnunet-fs-gtk_anonymity-widgets.c gnunet-fs-gtk_anonymity-widgets.h \
18 gnunet-fs-gtk_common.c gnunet-fs-gtk_common.h \ 19 gnunet-fs-gtk_common.c gnunet-fs-gtk_common.h \
19 gnunet-fs-gtk_create-pseudonym.c \ 20 gnunet-fs-gtk_create-pseudonym.c \
@@ -28,7 +29,11 @@ gnunet_fs_gtk_SOURCES = \
28 gnunet-fs-gtk_unindex.c gnunet-fs-gtk_unindex.h \ 29 gnunet-fs-gtk_unindex.c gnunet-fs-gtk_unindex.h \
29 gnunet-fs-gtk_publish-dialog.c \ 30 gnunet-fs-gtk_publish-dialog.c \
30 gnunet-fs-gtk_publish-edit-dialog.c gnunet-fs-gtk_publish-edit-dialog.h \ 31 gnunet-fs-gtk_publish-edit-dialog.c gnunet-fs-gtk_publish-edit-dialog.h \
31 gnunet-fs-gtk_namespace_manager.c 32 gnunet-fs-gtk_namespace_organizer.c \
33 gnunet-fs-gtk_namespace_organizer.h \
34 gnunet-fs-gtk_namespace_manager.c \
35 gnunet-fs-gtk_namespace_manager.h
36
32gnunet_fs_gtk_LDADD = \ 37gnunet_fs_gtk_LDADD = \
33 $(top_builddir)/src/lib/libgnunetgtk.la \ 38 $(top_builddir)/src/lib/libgnunetgtk.la \
34 @GTK_LIBS@ \ 39 @GTK_LIBS@ \