aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 23 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 2487143a..202387b8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,12 +3,31 @@
3SUBDIRS = contrib doc po src pixmaps 3SUBDIRS = contrib doc po src pixmaps
4 4
5desktopdir = $(datadir)/applications 5desktopdir = $(datadir)/applications
6desktop_in_files = gnunet-gtk.desktop.in 6desktop_in_files = \
7 gnunet-fs-gtk.desktop.in \
8 gnunet-setup.desktop.in
7desktop_DATA = $(desktop_in_files:.desktop.in=.desktop) 9desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
8 10
9pkgpixdir= $(pkgdatadir) 11pkgpixdir= $(pkgdatadir)
10 12
11EXTRA_DIST = config.rpath \
12 install-sh mkinstalldirs
13
14ACLOCAL_AMFLAGS = -I m4 13ACLOCAL_AMFLAGS = -I m4
14
15IMAGES = \
16 gnunet-setup-oxygen-cancel.png \
17 gnunet-setup-oxygen-ok.png
18
19pkgpixdir= $(pkgdatadir)
20
21install-data-local:
22 @$(NORMAL_INSTALL)
23 $(mkinstalldirs) $(DESTDIR)$(pkgpixdir)
24 for pixmap in $(IMAGES); do \
25 if test -f $$pixmap; then \
26 $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgpixdir); \
27 fi \
28 done
29
30EXTRA_DIST = \
31 config.rpath \
32 install-sh mkinstalldirs \
33 $(IMAGES)