aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c708be57..2154cc85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,7 +118,7 @@ AC_CHECK_HEADERS([errno.h stdio.h unistd.h locale.h sys/stat.h sys/types.h langi
118 118
119GNUNET_FS_APP="fs" 119GNUNET_FS_APP="fs"
120AC_ARG_ENABLE([fs-app], 120AC_ARG_ENABLE([fs-app],
121 AS_HELP_STRING([--disable-fs-app],[Do not build gnunet-fs application])) 121 AS_HELP_STRING([--disable-fs-app],[Do not build gnunet-fs-gtk application]))
122AS_IF([test "x$enable_fs_app" != "xno"], [ 122AS_IF([test "x$enable_fs_app" != "xno"], [
123 GNUNET_FS_APP="fs" 123 GNUNET_FS_APP="fs"
124]) 124])
@@ -132,6 +132,14 @@ AS_IF([test "x$enable_setup_app" != "xno"], [
132]) 132])
133AC_SUBST(GNUNET_SETUP_APP) 133AC_SUBST(GNUNET_SETUP_APP)
134 134
135GNUNET_PEERINFO_APP=""
136AC_ARG_ENABLE([peerinfo-app],
137 AS_HELP_STRING([--disable-peerinfo-app],[Do not build gnunet-peerinfo-gtk application]))
138AS_IF([test "x$enable_peerinfo_app" != "xno"], [
139 GNUNET_PEERINFO_APP="peerinfo"
140])
141AC_SUBST(GNUNET_PEERINFO_APP)
142
135# test for libextractor 143# test for libextractor
136extractor=0 144extractor=0
137AC_MSG_CHECKING(for libextractor) 145AC_MSG_CHECKING(for libextractor)
@@ -152,14 +160,14 @@ AC_ARG_WITH(extractor,
152 ], 160 ],
153 [AC_MSG_RESULT([--with-extractor not specified]) 161 [AC_MSG_RESULT([--with-extractor not specified])
154 AC_CHECK_HEADERS(extractor.h,extractor=1)]) 162 AC_CHECK_HEADERS(extractor.h,extractor=1)])
155if test "$extractor" != 1 163if test "$extractor" != 1
156then 164then
157 AC_MSG_ERROR([gnunet-gtk requires libextractor headers]) 165 AC_MSG_ERROR([gnunet-gtk requires libextractor headers])
158fi 166fi
159 167
160# check for gtk >= 2.6.0 168# check for gtk >= 3.0.0
161AC_MSG_CHECKING(for gtk) 169AC_MSG_CHECKING(for gtk)
162AM_PATH_GTK_2_0(2.6.0,without_gtk=false,without_gtk=true) 170AM_PATH_GTK_3_0(3.0.0,without_gtk=false,without_gtk=true)
163AM_CONDITIONAL(HAVE_GTK, test x$without_gtk != xtrue) 171AM_CONDITIONAL(HAVE_GTK, test x$without_gtk != xtrue)
164if test $without_gtk != true 172if test $without_gtk != true
165then 173then