aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0febb65a..683e7305 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,9 @@ then
53 CFLAGS="-fno-strict-aliasing $CFLAGS" 53 CFLAGS="-fno-strict-aliasing $CFLAGS"
54fi 54fi
55 55
56# Default to unix configuration
57ENABLE_ON_UNIX=""
58ENABLE_ON_W32="#"
56# Check system type 59# Check system type
57case "$host_os" in 60case "$host_os" in
58*darwin* | *rhapsody* | *macosx*) 61*darwin* | *rhapsody* | *macosx*)
@@ -88,6 +91,8 @@ netbsd*)
88 AC_DEFINE_UNQUOTED(WINDOWS,1,[This is a Windows system]) 91 AC_DEFINE_UNQUOTED(WINDOWS,1,[This is a Windows system])
89 AC_CHECK_LIB(intl, gettext) 92 AC_CHECK_LIB(intl, gettext)
90 LDFLAGS="$LDFLAGS -no-undefined" 93 LDFLAGS="$LDFLAGS -no-undefined"
94 ENABLE_ON_W32=""
95 ENABLE_ON_UNIX="#"
91 build_target="cygwin" 96 build_target="cygwin"
92 ;; 97 ;;
93*mingw*) 98*mingw*)
@@ -98,6 +103,8 @@ netbsd*)
98 LDFLAGS="$LDFLAGS -Wl,-no-undefined -Wl,--export-all-symbols -lws2_32" 103 LDFLAGS="$LDFLAGS -Wl,-no-undefined -Wl,--export-all-symbols -lws2_32"
99 CFLAGS="-mms-bitfields $CFLAGS" 104 CFLAGS="-mms-bitfields $CFLAGS"
100 LIBS="$LIBS -lws2_32 -lplibc -lole32" 105 LIBS="$LIBS -lws2_32 -lplibc -lole32"
106 ENABLE_ON_W32=""
107 ENABLE_ON_UNIX="#"
101 build_target="mingw" 108 build_target="mingw"
102 ;; 109 ;;
103*) 110*)
@@ -108,6 +115,9 @@ esac
108 115
109AM_CONDITIONAL(MINGW, test "$build_target" = "mingw") 116AM_CONDITIONAL(MINGW, test "$build_target" = "mingw")
110 117
118AC_SUBST(ENABLE_ON_UNIX)
119AC_SUBST(ENABLE_ON_W32)
120
111GN_LIB_LDFLAGS="-export-dynamic -no-undefined" 121GN_LIB_LDFLAGS="-export-dynamic -no-undefined"
112AC_SUBST(GN_LIB_LDFLAGS) 122AC_SUBST(GN_LIB_LDFLAGS)
113 123
@@ -500,6 +510,7 @@ src/Makefile
500src/include/Makefile 510src/include/Makefile
501src/lib/Makefile 511src/lib/Makefile
502src/fs/Makefile 512src/fs/Makefile
513src/fs/gnunet-fs-gtk.conf
503src/peerinfo/Makefile 514src/peerinfo/Makefile
504src/setup/Makefile 515src/setup/Makefile
505src/statistics/Makefile 516src/statistics/Makefile