aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 6 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 738b74ba..98adc199 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,23 +228,13 @@ then
228fi 228fi
229 229
230 230
231# Set PACKAGE_LOCALE_DIR in config.h. 231# We define the paths here, because MinGW/GCC expands paths
232if test "x${prefix}" = "xNONE"; then 232# passed through the command line ("-DDATADIR=..."). This would
233 AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "${ac_default_prefix}/${DATADIRNAME}/locale", [locale dir]) 233# lead to hard-coded paths ("C:\mingw\mingw\bin...") that do
234else 234# not contain the actual installation.
235 AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "${prefix}/${DATADIRNAME}/locale", [locale dir]) 235AC_DEFINE_DIR([PACKAGE_DATA_DIR], [datadir/GNUnet], [The directory for installing read-only architecture-independent data])
236fi 236AC_DEFINE_DIR([PACKAGE_LOCALE_DIR], [datadir/locale], [gettext catalogs])
237 237
238# Set PACKAGE_DATA_DIR in config.h.
239if test "x${datadir}" = 'x${prefix}/share'; then
240 if test "x${prefix}" = "xNONE"; then
241 AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${ac_default_prefix}/share/${PACKAGE}", [data dir])
242 else
243 AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${prefix}/share/${PACKAGE}", [data dir])
244 fi
245else
246 AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${datadir}/${PACKAGE}", [package data dir])
247fi
248 238
249# Set PACKAGE_SOURCE_DIR in config.h. 239# Set PACKAGE_SOURCE_DIR in config.h.
250packagesrcdir=`cd $srcdir && pwd` 240packagesrcdir=`cd $srcdir && pwd`