aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 6 insertions, 41 deletions
diff --git a/configure.ac b/configure.ac
index 63f6a017..bf6652df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -225,51 +225,16 @@ AC_SUBST(QR_LIBS)
225 225
226 226
227AC_MSG_CHECKING(for gtk) 227AC_MSG_CHECKING(for gtk)
228check_for_3=3.0.0
229check_for_2=false
230AC_ARG_WITH(gtk_version,
231 [ --with-gtk-version=VERSION version number of gtk to use (>=3.0.0 by default)],
232 [AC_MSG_RESULT([$with_gtk_version])
233 case $with_gtk_version in
234 *)
235 if test "x${with_gtk_version:0:1}" == "x2"
236 then
237 check_for_3=false
238 check_for_2=$with_gtk_version
239 elif test "x${with_gtk_version:0:1}" == "x3"
240 then
241 check_for_3=$with_gtk_version
242 check_for_2=false
243 fi
244 ;;
245 esac
246 ],
247 [AC_MSG_RESULT([--with-gtk-version not specified])])
248
249without_gtk=true 228without_gtk=true
250if test "x$check_for_3" != "xfalse" 229AM_PATH_GTK_3_0([3.0.0],without_gtk=false,)
251then
252 AM_PATH_GTK_3_0([$check_for_3],without_gtk=false,)
253 # test for libunique
254 AC_ARG_WITH([libunique], AC_HELP_STRING([--without-libunique], [disable libunique]))
255 have_libunique=no
256 if test x$with_libunique != xno; then
257 PKG_CHECK_MODULES([unique], [unique-3.0], AC_DEFINE(HAVE_LIBUNIQUE, 1, [Define if libunique is available]), AC_MSG_WARN([libunique would be nice to have]))
258 fi
259fi
260 230
261if test "x$without_gtk" == "xtrue" -a "x$check_for_2" != "xfalse" 231# test for libunique
262then 232AC_ARG_WITH([libunique], AC_HELP_STRING([--without-libunique], [disable libunique]))
263 AM_PATH_GTK_2_0([$check_for_2],without_gtk=false,) 233have_libunique=no
264 # test for libunique 234if test x$with_libunique != xno; then
265 AC_ARG_WITH([libunique], AC_HELP_STRING([--without-libunique], [disable libunique])) 235 PKG_CHECK_MODULES([unique], [unique-3.0], AC_DEFINE(HAVE_LIBUNIQUE, 1, [Define if libunique is available]), AC_MSG_WARN([libunique would be nice to have]))
266 have_libunique=no
267 if test x$with_libunique != xno; then
268 PKG_CHECK_MODULES([unique], [unique-1.0], AC_DEFINE(HAVE_LIBUNIQUE, 1, [Define if libunique is available]), AC_MSG_WARN([libunique would be nice to have]))
269 fi
270fi 236fi
271 237
272
273AM_CONDITIONAL(HAVE_GTK, test x$without_gtk != xtrue) 238AM_CONDITIONAL(HAVE_GTK, test x$without_gtk != xtrue)
274if test $without_gtk != true 239if test $without_gtk != true
275then 240then