diff options
Diffstat (limited to 'libltdl/configure.ac')
-rw-r--r-- | libltdl/configure.ac | 80 |
1 files changed, 0 insertions, 80 deletions
diff --git a/libltdl/configure.ac b/libltdl/configure.ac deleted file mode 100644 index 56c9f237..00000000 --- a/libltdl/configure.ac +++ /dev/null | |||
@@ -1,80 +0,0 @@ | |||
1 | ## Process this file with autoconf to create configure. -*- autoconf -*- | ||
2 | # Copyright 2001 Free Software Foundation, Inc. | ||
3 | # | ||
4 | # This program is free software; you can redistribute it and/or modify | ||
5 | # it under the terms of the GNU General Public License as published by | ||
6 | # the Free Software Foundation; either version 2 of the License, or | ||
7 | # (at your option) any later version. | ||
8 | # | ||
9 | # This program is distributed in the hope that it will be useful, | ||
10 | # but WITHOUT ANY WARRANTY; without even the implied warranty of | ||
11 | # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the | ||
12 | # GNU General Public License for more details. | ||
13 | # | ||
14 | # You should have received a copy of the GNU General Public License | ||
15 | # along with this program; if not, write to the Free Software | ||
16 | # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA | ||
17 | # 02111-1307 USA | ||
18 | |||
19 | |||
20 | ## FIXME: Is this really new enough? ## | ||
21 | AC_PREREQ(2.50) | ||
22 | |||
23 | |||
24 | ## ------------------------ ## | ||
25 | ## Autoconf initialisation. ## | ||
26 | ## ------------------------ ## | ||
27 | AC_INIT([libltdl], [1.2], [bug-libtool@gnu.org]) | ||
28 | AC_CONFIG_SRCDIR([ltdl.c]) | ||
29 | |||
30 | |||
31 | ## ------------------------------- ## | ||
32 | ## Libltdl specific configuration. ## | ||
33 | ## ------------------------------- ## | ||
34 | |||
35 | AC_CONFIG_AUX_DIR([.]) | ||
36 | |||
37 | if test -z "$enable_ltdl_install$enable_ltdl_convenience"; then | ||
38 | if test -f ${srcdir}/ltmain.sh; then | ||
39 | # if libltdl is libtoolized, it is assumed to be stand-alone and | ||
40 | # installed unless the command line overrides it (tested above) | ||
41 | enable_ltdl_install=yes | ||
42 | else | ||
43 | AC_MSG_WARN([*** The top-level configure must select either]) | ||
44 | AC_MSG_WARN([*** [A""C_LIBLTDL_INSTALLABLE] or [A""C_LIBLTDL_CONVENIENCE].]) | ||
45 | AC_MSG_ERROR([*** Maybe you want to --enable-ltdl-install?]) | ||
46 | fi | ||
47 | fi | ||
48 | |||
49 | |||
50 | ## ------------------------ ## | ||
51 | ## Automake Initialisation. ## | ||
52 | ## ------------------------ ## | ||
53 | AM_INIT_AUTOMAKE(AC_PACKAGE_TARNAME, AC_PACKAGE_VERSION, -) | ||
54 | AM_CONFIG_HEADER([config.h:config-h.in]) | ||
55 | AM_MAINTAINER_MODE | ||
56 | |||
57 | |||
58 | ## ------------------ ## | ||
59 | ## C compiler checks. ## | ||
60 | ## ------------------ ## | ||
61 | AC_PROG_CC | ||
62 | AC_C_CONST | ||
63 | AC_C_INLINE | ||
64 | |||
65 | |||
66 | ## ----------------------- ## | ||
67 | ## Libtool initialisation. ## | ||
68 | ## ----------------------- ## | ||
69 | AC_LIBTOOL_WIN32_DLL | ||
70 | AC_PROG_LIBTOOL | ||
71 | AC_SUBST([LIBTOOL_DEPS]) | ||
72 | |||
73 | AC_LIB_LTDL | ||
74 | |||
75 | |||
76 | ## -------- ## | ||
77 | ## Outputs. ## | ||
78 | ## -------- ## | ||
79 | AC_CONFIG_FILES([Makefile]) | ||
80 | AC_OUTPUT | ||