aboutsummaryrefslogtreecommitdiff
path: root/pixmaps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pixmaps/Makefile.am')
-rw-r--r--pixmaps/Makefile.am39
1 files changed, 37 insertions, 2 deletions
diff --git a/pixmaps/Makefile.am b/pixmaps/Makefile.am
index 608aef06..b447360e 100644
--- a/pixmaps/Makefile.am
+++ b/pixmaps/Makefile.am
@@ -1,3 +1,38 @@
1## Process this file with automake to produce Makefile.in 1theme=hicolor
2themedir="$(datadir)/icons/$(theme)"
3theme_icons = \
4 apps,gnunet-gtk.svg \
5 apps,gnunet-gtk-16.png \
6 apps,gnunet-gtk-22.png \
7 apps,gnunet-gtk-24.png \
8 apps,gnunet-gtk-32.png
2 9
3SUBDIRS = icons . 10pkgpixdir= $(pkgdatadir)
11
12install_icon_exec=${top_srcdir}/pixmaps/icon-theme-installer -d "x${DESTDIR}" -t ${theme} -s ${srcdir} -b ${themedir} -m "${mkinstalldirs}" -x "${INSTALL_DATA}"
13
14install-data-local:
15 $(mkinstalldirs) $(DESTDIR)$(pkgpixdir)
16 $(mkinstalldirs) $(DESTDIR)$(pkgpixdir)/flags
17 @$(NORMAL_INSTALL)
18 for pixmap in $(srcdir)/pixmaps/*.{png,svg}; do \
19 if test -f $$pixmap; then \
20 $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgpixdir); \
21 fi \
22 done
23 $(install_icon_exec) -i "${theme_icons}"
24
25dist-hook:
26 mkdir $(distdir)/pixmaps; \
27 for pixmap in $(srcdir)/pixmaps/*.{png,svg}; do \
28 if test -f $$pixmap; then \
29 cp -p $$pixmap $(distdir)/pixmaps; \
30 fi \
31 done
32
33
34uninstall-hook:
35 $(install_icon_exec) -u "${theme_icons}"
36
37MAINTAINERCLEANFILES = Makefile.in
38EXTRA_DIST = gnunet-gtk.svg gnunet-gtk-16.png gnunet-gtk-22.png gnunet-gtk-24.png gnunet-gtk-32.png icon-theme-installer