aboutsummaryrefslogtreecommitdiff
path: root/pixmaps/icons/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pixmaps/icons/Makefile.am')
-rw-r--r--pixmaps/icons/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/pixmaps/icons/Makefile.am b/pixmaps/icons/Makefile.am
new file mode 100644
index 00000000..f76389b2
--- /dev/null
+++ b/pixmaps/icons/Makefile.am
@@ -0,0 +1,20 @@
1theme=hicolor
2 themedir=$(datadir)/icons/$(theme)
3 theme_icons = \
4 apps,gnunet-gtk.svg \
5 apps,gnunet-gtk-16.png \
6 apps,gnunet-gtk-22.png \
7 apps,gnunet-gtk-24.png \
8 apps,gnunet-gtk-32.png
9
10 install_icon_exec = $(top_srcdir)/pixmaps/icons/icon-theme-installer -t
11$(theme) -s $(srcdir) -d "x$(DESTDIR)" -b $(themedir) -m
12"$(mkinstalldirs)" -x "$(INSTALL_DATA)"
13 install-data-local:
14 $(install_icon_exec) -i $(theme_icons)
15
16 uninstall-hook:
17 $(install_icon_exec) -u $(theme_icons)
18
19 MAINTAINERCLEANFILES = Makefile.in
20 EXTRA_DIST = $(wildcard *.svg *.png)