aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am33
1 files changed, 32 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1043ff02..e329755c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1 +1,32 @@
1SUBDIRS = include common core plugins 1SUBDIRS = .
2
3INCLUDES = \
4 -I$(top_srcdir)/ \
5 @GTK_CFLAGS@ \
6 @GNUNETGTK_CFLAGS@
7
8bin_PROGRAMS = gnunet-gtk
9
10gnunet_gtk_SOURCES = \
11 about.c \
12 common.c common.h \
13 download.c download.h \
14 edit_publish_dialog.c edit_publish_dialog.h \
15 fs_event_handler.c fs_event_handler.h \
16 fs_anonymity_spin_buttons.c \
17 gnunet-gtk.c \
18 main_window_create_pseudonym.c \
19 main_window_file_download.c \
20 main_window_file_publish.c \
21 main_window_file_search.c \
22 main_window_open_directory.c \
23 main_window_view_toggles.c \
24 peerinfo.c peerinfo.h
25gnunet_gtk_LDADD = \
26 @GTK_LIBS@ \
27 -lgnunetutil \
28 -lgnunetpeerinfo \
29 -lgnunetfs \
30 $(INTLLIBS)
31gnunet_gtk_LDFLAGS = \
32 -export-dynamic \ No newline at end of file