diff options
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r-- | src/fs/Makefile.am | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am new file mode 100644 index 00000000..1bca5573 --- /dev/null +++ b/src/fs/Makefile.am | |||
@@ -0,0 +1,36 @@ | |||
1 | SUBDIRS = . | ||
2 | |||
3 | INCLUDES = \ | ||
4 | -I$(top_srcdir)/ \ | ||
5 | -I$(top_srcdir)/src/include \ | ||
6 | @GTK_CFLAGS@ \ | ||
7 | @GNUNET_CFLAGS@ \ | ||
8 | @GLADE_CFLAGS@ | ||
9 | |||
10 | bin_PROGRAMS = gnunet-fs-gtk | ||
11 | |||
12 | gnunet_fs_gtk_SOURCES = \ | ||
13 | about.c \ | ||
14 | common.c common.h \ | ||
15 | download.c download.h \ | ||
16 | edit_publish_dialog.c edit_publish_dialog.h \ | ||
17 | fs_event_handler.c fs_event_handler.h \ | ||
18 | fs_anonymity_spin_buttons.c \ | ||
19 | gnunet-fs-gtk.c gnunet-fs-gtk.h \ | ||
20 | main_window_create_pseudonym.c \ | ||
21 | main_window_file_download.c \ | ||
22 | main_window_file_publish.c \ | ||
23 | main_window_file_search.c \ | ||
24 | main_window_open_directory.c \ | ||
25 | main_window_adv_pseudonym.c \ | ||
26 | main_window_view_toggles.c | ||
27 | gnunet_fs_gtk_LDADD = \ | ||
28 | $(top_builddir)/src/lib/libgnunetgtk.la \ | ||
29 | @GTK_LIBS@ \ | ||
30 | @GLADE_LIBS@ \ | ||
31 | -lextractor \ | ||
32 | -lgnunetutil \ | ||
33 | -lgnunetfs \ | ||
34 | $(INTLLIBS) | ||
35 | gnunet_fs_gtk_LDFLAGS = \ | ||
36 | -export-dynamic | ||