aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/peers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/peers/Makefile.am')
-rw-r--r--src/plugins/peers/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/plugins/peers/Makefile.am b/src/plugins/peers/Makefile.am
new file mode 100644
index 00000000..2084c2b0
--- /dev/null
+++ b/src/plugins/peers/Makefile.am
@@ -0,0 +1,24 @@
1INCLUDES = \
2 -I$(top_srcdir)/intl \
3 -I$(top_srcdir)/src/include \
4 @GTK_CFLAGS@ \
5 @GNUNETGTK_CFLAGS@
6
7plugindir = $(libdir)/GNUnet
8
9plugin_LTLIBRARIES = \
10 libgnunetgtkmodule_peers.la
11
12libgnunetgtkmodule_peers_la_SOURCES = \
13 peers.c
14libgnunetgtkmodule_peers_la_LIBADD = \
15 @GTK_LIBS@ @GNUNETGTK_LIBS@ \
16 $(top_builddir)/src/common/libgnunetgtk_common.la \
17 -lgnunetutil \
18 -lgnunetutil_cron \
19 -lgnunetutil_config \
20 -lgnunetidentity_api \
21 -lgnunetgetoption_api \
22 -lgnunetutil_network_client
23libgnunetgtkmodule_peers_la_LDFLAGS = \
24 -export-dynamic -avoid-version -module