aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjospaeth <spaethj@in.tum.de>2020-08-15 16:25:11 +0200
committerjospaeth <spaethj@in.tum.de>2020-08-15 16:25:11 +0200
commit72a66ee46f2b2bcb3d2cc4376c6c7dc6b57c86aa (patch)
tree281f68831ea8527eea4b6641767a9cd0b5b91817 /configure.ac
parent91d9d4251d3b1d0fab1780da73b6969581d22ffe (diff)
parentf1f40feb2beb5c036da0e2b93c433b09b920e0b4 (diff)
downloadgnunet-72a66ee46f2b2bcb3d2cc4376c6c7dc6b57c86aa.tar.gz
gnunet-72a66ee46f2b2bcb3d2cc4376c6c7dc6b57c86aa.zip
Merge branch 'master' into spaeth/escrow_plugins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5c79ff2af..4dacfa8ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,7 @@
21# 21#
22AC_PREREQ(2.61) 22AC_PREREQ(2.61)
23# Checks for programs. 23# Checks for programs.
24AC_INIT([gnunet], [0.13.1], [bug-gnunet@gnu.org]) 24AC_INIT([gnunet], [0.13.2], [bug-gnunet@gnu.org])
25AC_CONFIG_AUX_DIR([build-aux]) 25AC_CONFIG_AUX_DIR([build-aux])
26 26
27# check for legacy option that is no longer supported (#5627) and fail hard 27# check for legacy option that is no longer supported (#5627) and fail hard
@@ -1432,12 +1432,11 @@ AS_IF([test "$mysql" = "true" -a "x$enable_mysql_version_check" = "xyes"],
1432 AC_MSG_CHECKING(mysql version) 1432 AC_MSG_CHECKING(mysql version)
1433 AC_COMPILE_IFELSE([AC_LANG_PROGRAM( 1433 AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
1434 [[ 1434 [[
1435 #include <mysql/mysql.h>]], 1435 #include <mysql/mysql_version.h>]],
1436 [[ 1436 [[
1437 #if (MYSQL_VERSION_ID < 40100) 1437 #if (MYSQL_VERSION_ID < 40100)
1438 #error needs at least version >= 4.1 1438 #error needs at least version >= 4.1
1439 #endif 1439 #endif
1440 int main () { return 0; }
1441 ]]) 1440 ]])
1442 ], 1441 ],
1443 [mysql=true], 1442 [mysql=true],
@@ -1451,6 +1450,21 @@ AS_IF([test "$mysql" = "true" -a "x$enable_mysql_version_check" = "xyes"],
1451 mysqlfail=false 1450 mysqlfail=false
1452 AC_MSG_RESULT(ok) 1451 AC_MSG_RESULT(ok)
1453 ]) 1452 ])
1453 AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
1454 [[
1455 #include <mysql/mysql_version.h>]],
1456 [[
1457 #if (MYSQL_VERSION_ID < 80000)
1458 #error needs at least version >= 4.1
1459 #endif
1460 ]])
1461 ],
1462 [mysql8=true],
1463 [mysql8=false])
1464 AS_IF([test x$mysql8 = xtrue],
1465 [
1466 AC_DEFINE([HAVE_MYSQL8],[1],[Have mysql8])
1467 ],[])
1454]) 1468])
1455 1469
1456AM_CONDITIONAL(HAVE_MYSQL, test x$mysql = xtrue) 1470AM_CONDITIONAL(HAVE_MYSQL, test x$mysql = xtrue)