aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2017-08-03 19:21:28 +0900
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2017-08-03 19:21:28 +0900
commit02c92c69ab4193b81ac6f90b52fecb40b94b9208 (patch)
tree0cbbfc249451abd23b238a811f42015df95bbe2a /configure.ac
parentb6755fe23d258a4dc971d8fabc3fae1873e31271 (diff)
parent6bcc73a1cbb1d4a609884762eab1b6de761ad1d9 (diff)
downloadgnunet-02c92c69ab4193b81ac6f90b52fecb40b94b9208.tar.gz
gnunet-02c92c69ab4193b81ac6f90b52fecb40b94b9208.zip
Merge remote-tracking branch 'origin/master' into identity_abe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 0 insertions, 47 deletions
diff --git a/configure.ac b/configure.ac
index bfde625d2..027724774 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1137,45 +1137,6 @@ AC_SUBST(SUDO_BINARY)
1137AM_CONDITIONAL([HAVE_SUDO], [test "x$SUDO_BINARY" != "x" -o -w /]) 1137AM_CONDITIONAL([HAVE_SUDO], [test "x$SUDO_BINARY" != "x" -o -w /])
1138 1138
1139 1139
1140# test for nssdir
1141AC_MSG_CHECKING(with nssdir)
1142AC_ARG_WITH(nssdir,
1143 [ --with-nssdir=PATH where to install NSS plugins],
1144 [AC_MSG_RESULT("$with_nssdir")
1145 case $with_nssdir in
1146 no)
1147 NSS_DIR=
1148 install_nss=0
1149 ;;
1150 yes)
1151 NSS_DIR="/lib"
1152 install_nss=1
1153 ;;
1154 *)
1155 NSS_DIR=$with_nssdir
1156 install_nss=1
1157 ;;
1158 esac
1159 ],
1160 [
1161# This test is inappropriate when installation with DESTDIR is
1162# run much later and uid will be root when needed. Enabling this
1163# code breaks the gnunet.ebuild for gentoo.
1164#
1165# if test "x$SUDO_BINARY" != "x" -o -w /
1166# then
1167 NSS_DIR="/lib"
1168 install_nss=1
1169 AC_MSG_RESULT([yes, to /lib])
1170# else
1171# NSS_DIR=
1172# install_nss=0
1173# AC_MSG_RESULT([no])
1174# fi
1175 ])
1176AC_SUBST(NSS_DIR)
1177AM_CONDITIONAL([INSTALL_NSS], [test "x$install_nss" != "x0"])
1178
1179# test for gnunetdns group name 1140# test for gnunetdns group name
1180GNUNETDNS_GROUP=gnunetdns 1141GNUNETDNS_GROUP=gnunetdns
1181AC_MSG_CHECKING(for gnunetdns group name) 1142AC_MSG_CHECKING(for gnunetdns group name)
@@ -1816,14 +1777,6 @@ then
1816 AC_MSG_NOTICE([Mac OS X framework build enabled.]) 1777 AC_MSG_NOTICE([Mac OS X framework build enabled.])
1817fi 1778fi
1818 1779
1819if test "x$install_nss" = "x0"
1820then
1821 AC_MSG_NOTICE([WARNING: Will not install GNS NSS library])
1822else
1823 AC_MSG_NOTICE([NOTICE: Will install GNS NSS library to $NSS_DIR])
1824fi
1825
1826
1827AC_MSG_NOTICE([******************************************** 1780AC_MSG_NOTICE([********************************************
1828Please make sure NOW that you have created a user and group 'gnunet' 1781Please make sure NOW that you have created a user and group 'gnunet'
1829and additionally a group 'gnunetdns'. On Debian and Ubuntu GNU/Linux, type: 1782and additionally a group 'gnunetdns'. On Debian and Ubuntu GNU/Linux, type: