aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-12-04 22:01:23 +0900
committerMartin Schanzenbach <schanzen@gnunet.org>2022-12-04 22:01:23 +0900
commit3f0d91045d29435feef723f09f9ff75c80296d3d (patch)
tree15a0e4c16ec1a5ecdb6472f24136aedb99ef2b47 /configure.ac
parenta0914a0ad18728e4b2b1632198d50d8b001a8890 (diff)
downloadgnunet-3f0d91045d29435feef723f09f9ff75c80296d3d.tar.gz
gnunet-3f0d91045d29435feef723f09f9ff75c80296d3d.zip
BUILD: Remove static_assert check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 04c539bf3..81d678ecd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -597,16 +597,6 @@ gcry_md_close (mac);]])],
597 [AC_MSG_RESULT([cross compiling, test skipped])]) 597 [AC_MSG_RESULT([cross compiling, test skipped])])
598 AC_LANG_POP([C])]) 598 AC_LANG_POP([C])])
599 599
600AC_MSG_CHECKING([for static assertion support])
601AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],
602 [[_Static_assert(sizeof(int) >= 4, "not big enough");]])],
603 [AC_MSG_RESULT([yes])
604 AC_DEFINE([HAVE_STATIC_ASSERT], [1],
605 [Define to 1 if static assert is supported])],
606 [AC_MSG_RESULT([no])
607 AC_DEFINE([HAVE_STATIC_ASSERT], [0],
608 [Define to 1 if static assert is supported])])
609
610dnl Helper function to shorten the amount of repeated code 600dnl Helper function to shorten the amount of repeated code
611dnl It will create a --with-<lib> option for configure. 601dnl It will create a --with-<lib> option for configure.
612dnl 602dnl