aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2009-07-17 12:59:05 +0000
committerChristian Grothoff <christian@grothoff.org>2009-07-17 12:59:05 +0000
commitee070fe6f1caa8fbf81d770c8685939a91b2cbc5 (patch)
treeec72b322782b986ad4c5d6220ced08476fba9ec4 /configure.ac
parent8146ad014b181ea88150d67a9780eea2103ae446 (diff)
downloadgnunet-ee070fe6f1caa8fbf81d770c8685939a91b2cbc5.tar.gz
gnunet-ee070fe6f1caa8fbf81d770c8685939a91b2cbc5.zip
sthuff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 1 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index b4a294b17..30aeb32f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -711,20 +711,7 @@ fi
711 711
712GN_LIB_LDFLAGS="-export-dynamic -no-undefined" 712GN_LIB_LDFLAGS="-export-dynamic -no-undefined"
713GN_PLUGIN_LDFLAGS="-export-dynamic -avoid-version -module -no-undefined" 713GN_PLUGIN_LDFLAGS="-export-dynamic -avoid-version -module -no-undefined"
714dnl TODO insert a proper check here 714
715AC_CACHE_CHECK([whether -export-symbols-regex works],
716 gn_cv_export_symbols_regex_works,
717 [
718 case "$host_os" in
719 mingw*) gn_cv_export_symbols_regex_works=no;;
720 *) gn_cv_export_symbols_regex_works=yes;;
721 esac
722 ])
723if test "x$gn_cv_export_symbols_regex_works" = "xyes"
724then
725 GN_LIB_LDFLAGS="$GN_LIB_LDFLAGS -export-symbols-regex \"GNUNET_@<:@a-zA-Z0-9_@:>@*\""
726 GN_PLUGIN_LDFLAGS="$GN_PLUGIN_LDFLAGS -export-symbols-regex \"@<:@a-zA-Z0-9_@:>@*\""
727fi
728AC_SUBST(GN_LIB_LDFLAGS) 715AC_SUBST(GN_LIB_LDFLAGS)
729AC_SUBST(GN_PLUGIN_LDFLAGS) 716AC_SUBST(GN_PLUGIN_LDFLAGS)
730AC_SUBST(GN_INTLINCL) 717AC_SUBST(GN_INTLINCL)