aboutsummaryrefslogtreecommitdiff
path: root/contrib/hellos/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-04-06 15:35:56 +0000
committerng0 <ng0@n0.is>2019-04-06 15:35:56 +0000
commit09cb17e77bf978b2c449f572aa5a227ebf9ba8e9 (patch)
tree6c7cc8ddbcaa35aa9b4a069aeb1b824e1b19d665 /contrib/hellos/Makefile.am
parente0ec610391ad9e4139962f42d17d92bdda7c9c16 (diff)
downloadgnunet-09cb17e77bf978b2c449f572aa5a227ebf9ba8e9.tar.gz
gnunet-09cb17e77bf978b2c449f572aa5a227ebf9ba8e9.zip
Add missing Makefiles
Diffstat (limited to 'contrib/hellos/Makefile.am')
-rw-r--r--contrib/hellos/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/contrib/hellos/Makefile.am b/contrib/hellos/Makefile.am
new file mode 100644
index 000000000..18a6458fe
--- /dev/null
+++ b/contrib/hellos/Makefile.am
@@ -0,0 +1,22 @@
1# This Makefile.am is in the public domain
2
3pkghellodir= $(pkgdatadir)/hellos
4
5install-data-local:
6 $(mkinstalldirs) $(DESTDIR)$(pkghellodir)
7 @$(NORMAL_INSTALL)
8 for hello in $(srcdir)/hellos/*; do \
9 if test -f $$hello; then \
10 $(INSTALL_DATA) $$hello $(DESTDIR)$(pkghellodir)/ ; \
11 fi \
12 done
13
14dist-hook:
15 if test -d $(srcdir)/hellos; then \
16 mkdir -p $(distdir)/hellos; \
17 for hello in $(srcdir)/hellos/*; do \
18 if test -f $$hello; then \
19 cp -p $$hello $(distdir)/hellos; \
20 fi \
21 done \
22 fi