aboutsummaryrefslogtreecommitdiff
path: root/src/ats-tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-09-06 12:02:10 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-09-06 12:02:10 +0000
commit3a56bf7aa7e6de7d096cb509054b5dab1e50d119 (patch)
tree738e4396bd12f7f030f1b061a552f5f8d14cd82a /src/ats-tests/Makefile.am
parent4d3f7a77e8c79b639d1a1280a005def87dc227be (diff)
downloadgnunet-3a56bf7aa7e6de7d096cb509054b5dab1e50d119.tar.gz
gnunet-3a56bf7aa7e6de7d096cb509054b5dab1e50d119.zip
missing makefile.am
Diffstat (limited to 'src/ats-tests/Makefile.am')
-rw-r--r--src/ats-tests/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/ats-tests/Makefile.am b/src/ats-tests/Makefile.am
new file mode 100644
index 000000000..79010f06d
--- /dev/null
+++ b/src/ats-tests/Makefile.am
@@ -0,0 +1,50 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3pkgcfgdir= $(pkgdatadir)/config.d/
4
5libexecdir= $(pkglibdir)/libexec/
6
7if MINGW
8 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
9endif
10
11if USE_COVERAGE
12 AM_CFLAGS = -fprofile-arcs -ftest-coverage
13endif
14
15if HAVE_LIBGLPK
16
17endif
18
19if HAVE_TESTING
20TESTING_TESTS = \
21 perf_ats_proportional_bandwidth \
22 perf_ats_proportional_delay
23endif
24
25check_PROGRAMS = \
26 $(TESTING_TESTS)
27
28if ENABLE_TEST_RUN
29TESTS = $(check_PROGRAMS)
30endif
31
32perf_ats_proportional_bandwidth_SOURCES = \
33 perf_ats.c
34perf_ats_proportional_bandwidth_LDADD = \
35 $(top_builddir)/src/util/libgnunetutil.la \
36 $(top_builddir)/src/testbed/libgnunettestbed.la \
37 $(top_builddir)/src/ats/libgnunetats.la \
38 $(top_builddir)/src/core/libgnunetcore.la
39
40perf_ats_proportional_delay_SOURCES = \
41 perf_ats.c
42perf_ats_proportional_delay_LDADD = \
43 $(top_builddir)/src/util/libgnunetutil.la \
44 $(top_builddir)/src/testbed/libgnunettestbed.la \
45 $(top_builddir)/src/ats/libgnunetats.la \
46 $(top_builddir)/src/core/libgnunetcore.la
47
48EXTRA_DIST = \
49 perf_ats_proportional_bandwidth.conf \
50 perf_ats_proportional_delay.conf