aboutsummaryrefslogtreecommitdiff
path: root/src/ats-tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-09-18 07:49:00 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-09-18 07:49:00 +0000
commit475391ffb22f9016758ae53f6e7de81c424ee215 (patch)
tree2ba98c0cb6952db5984da1631698e1be8f64a628 /src/ats-tests/Makefile.am
parent7e5a7b84418a27b828c0b8ef10ddf8162df15cda (diff)
downloadgnunet-475391ffb22f9016758ae53f6e7de81c424ee215.tar.gz
gnunet-475391ffb22f9016758ae53f6e7de81c424ee215.zip
new test
Diffstat (limited to 'src/ats-tests/Makefile.am')
-rw-r--r--src/ats-tests/Makefile.am39
1 files changed, 35 insertions, 4 deletions
diff --git a/src/ats-tests/Makefile.am b/src/ats-tests/Makefile.am
index eace51e5d..931d3e5b5 100644
--- a/src/ats-tests/Makefile.am
+++ b/src/ats-tests/Makefile.am
@@ -13,17 +13,21 @@ if USE_COVERAGE
13endif 13endif
14 14
15if HAVE_LIBGLPK 15if HAVE_LIBGLPK
16 PERF_MLP_NONE = perf_ats_mlp_none
16 PERF_MLP_BANDWIDTH = perf_ats_mlp_bandwidth 17 PERF_MLP_BANDWIDTH = perf_ats_mlp_bandwidth
17 PERF_MLP_LATENCY = perf_ats_mlp_latency 18 PERF_MLP_LATENCY = perf_ats_mlp_latency
18endif 19endif
19 20
20if HAVE_TESTING 21if HAVE_TESTING
21TESTING_TESTS = \ 22TESTING_TESTS = \
23 perf_ats_proportional_none \
22 perf_ats_proportional_bandwidth \ 24 perf_ats_proportional_bandwidth \
23 perf_ats_proportional_latency 25 perf_ats_proportional_latency \
24 #perf_ats_ril_bandwidth \ 26 #perf_ats_mlp_none
25 #perf_ats_ril_latency \ 27 #perf_ats_mlp_bandwidth
26 #$(PERF_MLP_BANDWIDTH) $(PERF_MLP_LATENCY) 28 #perf_ats_ril_none
29 #perf_ats_ril_bandwidth
30 #perf_ats_ril_latency
27endif 31endif
28 32
29check_PROGRAMS = \ 33check_PROGRAMS = \
@@ -33,6 +37,14 @@ if ENABLE_TEST_RUN
33TESTS = $(check_PROGRAMS) 37TESTS = $(check_PROGRAMS)
34endif 38endif
35 39
40perf_ats_proportional_none_SOURCES = \
41 perf_ats.c
42perf_ats_proportional_none_LDADD = \
43 $(top_builddir)/src/util/libgnunetutil.la \
44 $(top_builddir)/src/testbed/libgnunettestbed.la \
45 $(top_builddir)/src/ats/libgnunetats.la \
46 $(top_builddir)/src/core/libgnunetcore.la
47
36perf_ats_proportional_bandwidth_SOURCES = \ 48perf_ats_proportional_bandwidth_SOURCES = \
37 perf_ats.c 49 perf_ats.c
38perf_ats_proportional_bandwidth_LDADD = \ 50perf_ats_proportional_bandwidth_LDADD = \
@@ -50,6 +62,14 @@ perf_ats_proportional_latency_LDADD = \
50 $(top_builddir)/src/core/libgnunetcore.la 62 $(top_builddir)/src/core/libgnunetcore.la
51 63
52if HAVE_LIBGLPK 64if HAVE_LIBGLPK
65perf_ats_mlp_none_SOURCES = \
66 perf_ats.c
67perf_ats_mlp_none_LDADD = \
68 $(top_builddir)/src/util/libgnunetutil.la \
69 $(top_builddir)/src/testbed/libgnunettestbed.la \
70 $(top_builddir)/src/ats/libgnunetats.la \
71 $(top_builddir)/src/core/libgnunetcore.la
72
53perf_ats_mlp_bandwidth_SOURCES = \ 73perf_ats_mlp_bandwidth_SOURCES = \
54 perf_ats.c 74 perf_ats.c
55perf_ats_mlp_bandwidth_LDADD = \ 75perf_ats_mlp_bandwidth_LDADD = \
@@ -67,6 +87,14 @@ perf_ats_mlp_latency_LDADD = \
67 $(top_builddir)/src/core/libgnunetcore.la 87 $(top_builddir)/src/core/libgnunetcore.la
68endif 88endif
69 89
90perf_ats_ril_none_SOURCES = \
91 perf_ats.c
92perf_ats_ril_none_LDADD = \
93 $(top_builddir)/src/util/libgnunetutil.la \
94 $(top_builddir)/src/testbed/libgnunettestbed.la \
95 $(top_builddir)/src/ats/libgnunetats.la \
96 $(top_builddir)/src/core/libgnunetcore.la
97
70perf_ats_ril_bandwidth_SOURCES = \ 98perf_ats_ril_bandwidth_SOURCES = \
71 perf_ats.c 99 perf_ats.c
72perf_ats_ril_bandwidth_LDADD = \ 100perf_ats_ril_bandwidth_LDADD = \
@@ -84,9 +112,12 @@ perf_ats_ril_latency_LDADD = \
84 $(top_builddir)/src/core/libgnunetcore.la 112 $(top_builddir)/src/core/libgnunetcore.la
85 113
86EXTRA_DIST = \ 114EXTRA_DIST = \
115 perf_ats_proportional_none.conf \
87 perf_ats_proportional_bandwidth.conf \ 116 perf_ats_proportional_bandwidth.conf \
88 perf_ats_proportional_latency.conf \ 117 perf_ats_proportional_latency.conf \
118 perf_ats_mlp_none.conf \
89 perf_ats_mlp_bandwidth.conf \ 119 perf_ats_mlp_bandwidth.conf \
90 perf_ats_mlp_latency.conf \ 120 perf_ats_mlp_latency.conf \
121 perf_ats_ril_none.conf \
91 perf_ats_ril_bandwidth.conf \ 122 perf_ats_ril_bandwidth.conf \
92 perf_ats_ril_latency.conf 123 perf_ats_ril_latency.conf