summaryrefslogtreecommitdiff
path: root/src/ats-tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2014-01-21 15:22:09 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2014-01-21 15:22:09 +0000
commit1f3f45c08b82899a5350633dc6f1030216a1e150 (patch)
tree1536f4ed581eed1139eb8a81663038c548dea038 /src/ats-tests/Makefile.am
parent42d205bed7f300dbc9fa4e97bb88b35321552a89 (diff)
downloadgnunet-1f3f45c08b82899a5350633dc6f1030216a1e150.tar.gz
gnunet-1f3f45c08b82899a5350633dc6f1030216a1e150.zip
initial preliminary commit for ats testing lib and simulator tool
Diffstat (limited to 'src/ats-tests/Makefile.am')
-rw-r--r--src/ats-tests/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/ats-tests/Makefile.am b/src/ats-tests/Makefile.am
index 1cdeb6b5b..8a90c6994 100644
--- a/src/ats-tests/Makefile.am
+++ b/src/ats-tests/Makefile.am
@@ -38,6 +38,9 @@ TESTING_TESTS = \
38 #perf_ats_ril_core_latency 38 #perf_ats_ril_core_latency
39endif 39endif
40 40
41lib_LTLIBRARIES = \
42 libgnunetatstesting.la
43
41check_PROGRAMS = \ 44check_PROGRAMS = \
42 $(TESTING_TESTS) 45 $(TESTING_TESTS)
43 46
@@ -45,6 +48,36 @@ if ENABLE_TEST_RUN
45TESTS = $(check_PROGRAMS) 48TESTS = $(check_PROGRAMS)
46endif 49endif
47 50
51noinst_PROGRAMS = \
52 gnunet-ats-sim
53
54libgnunetatstesting_la_SOURCES = \
55 ats-testing.c ats-testing.h
56libgnunetatstesting_la_LIBADD = \
57 $(top_builddir)/src/transport/libgnunettransport.la \
58 $(top_builddir)/src/hello/libgnunethello.la \
59 $(top_builddir)/src/util/libgnunetutil.la \
60 $(top_builddir)/src/testing/libgnunettesting.la \
61 $(GN_LIBINTL)
62libgnunettransporttesting_la_DEPENDENCIES = \
63 libgnunettransport.la
64libgnunettransporttesting_la_LDFLAGS = \
65 $(GN_LIB_LDFLAGS)
66
67gnunet_ats_sim_SOURCES = \
68 gnunet-ats-sim.c
69gnunet_ats_sim_LDADD = \
70 $(top_builddir)/src/util/libgnunetutil.la \
71 $(top_builddir)/src/ats-tests/libgnunetatstesting.la \
72 $(top_builddir)/src/testbed/libgnunettestbed.la \
73 $(top_builddir)/src/ats/libgnunetats.la \
74 $(top_builddir)/src/core/libgnunetcore.la \
75 $(top_builddir)/src/transport/libgnunettransport.la
76gnunet_ats_sim_DEPENDENCIES = \
77 $(top_builddir)/src/ats-tests/libgnunetatstesting.la \
78 $(top_builddir)/src/util/libgnunetutil.la
79
80
48perf_ats_proportional_core_none_SOURCES = \ 81perf_ats_proportional_core_none_SOURCES = \
49 perf_ats.c perf_ats_logging.c perf_ats.h 82 perf_ats.c perf_ats_logging.c perf_ats.h
50perf_ats_proportional_core_none_LDADD = \ 83perf_ats_proportional_core_none_LDADD = \