aboutsummaryrefslogtreecommitdiff
path: root/src/ats-tool/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2012-10-25 14:14:37 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2012-10-25 14:14:37 +0000
commit18d7de54a90ef3b2f7c562573bc95513119d3466 (patch)
treea2db35a1c6450c6beb1bbabcdf16a5b1e8fe132f /src/ats-tool/Makefile.am
parentd02ab50a92b6af0ed638febb147d9a2fab447dd5 (diff)
downloadgnunet-18d7de54a90ef3b2f7c562573bc95513119d3466.tar.gz
gnunet-18d7de54a90ef3b2f7c562573bc95513119d3466.zip
move ats-tool due to transport dependency
Diffstat (limited to 'src/ats-tool/Makefile.am')
-rw-r--r--src/ats-tool/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/ats-tool/Makefile.am b/src/ats-tool/Makefile.am
new file mode 100644
index 000000000..d39bef3e7
--- /dev/null
+++ b/src/ats-tool/Makefile.am
@@ -0,0 +1,21 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = -fprofile-arcs -ftest-coverage
9endif
10
11bin_PROGRAMS = \
12 gnunet-ats
13
14gnunet_ats_SOURCES = \
15 gnunet-ats.c gnunet-service-ats.h
16gnunet_ats_LDADD = \
17 $(top_builddir)/src/util/libgnunetutil.la \
18 $(top_builddir)/src/ats/libgnunetats.la \
19 $(top_builddir)/src/transport/libgnunettransport.la \
20 $(top_builddir)/src/hello/libgnunethello.la \
21 $(GN_LIBINTL) \ No newline at end of file