aboutsummaryrefslogtreecommitdiff
path: root/src/ats/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-12-06 18:38:43 +0100
committerChristian Grothoff <christian@grothoff.org>2018-12-06 18:38:43 +0100
commit5a1d7b406639cb12640c9906ca38c3c08f912a85 (patch)
tree2f41b3ef348f2525e8560406106647af6823b1a1 /src/ats/Makefile.am
parentaa6e0a1941f98ed90947aa5e3671438cb381995c (diff)
downloadgnunet-5a1d7b406639cb12640c9906ca38c3c08f912a85.tar.gz
gnunet-5a1d7b406639cb12640c9906ca38c3c08f912a85.zip
skeleton for 'simple' ATS2 plugin
Diffstat (limited to 'src/ats/Makefile.am')
-rw-r--r--src/ats/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/src/ats/Makefile.am b/src/ats/Makefile.am
index 52a1e7d11..97497c94e 100644
--- a/src/ats/Makefile.am
+++ b/src/ats/Makefile.am
@@ -24,7 +24,8 @@ lib_LTLIBRARIES = \
24 libgnunetatstransport.la 24 libgnunetatstransport.la
25 25
26plugin_LTLIBRARIES = \ 26plugin_LTLIBRARIES = \
27 libgnunet_plugin_ats_proportional.la 27 libgnunet_plugin_ats_proportional.la \
28 libgnunet_plugin_ats2_simple.la
28 29
29if HAVE_EXPERIMENTAL 30if HAVE_EXPERIMENTAL
30plugin_LTLIBRARIES += \ 31plugin_LTLIBRARIES += \
@@ -77,6 +78,15 @@ libgnunet_plugin_ats_proportional_la_LIBADD = \
77libgnunet_plugin_ats_proportional_la_LDFLAGS = \ 78libgnunet_plugin_ats_proportional_la_LDFLAGS = \
78 $(GN_PLUGIN_LDFLAGS) 79 $(GN_PLUGIN_LDFLAGS)
79 80
81libgnunet_plugin_ats2_simple_la_SOURCES = \
82 plugin_ats2_simple.c
83libgnunet_plugin_ats2_simple_la_LIBADD = \
84 $(top_builddir)/src/statistics/libgnunetstatistics.la \
85 $(top_builddir)/src/util/libgnunetutil.la \
86 $(LTLIBINTL)
87libgnunet_plugin_ats2_simple_la_LDFLAGS = \
88 $(GN_PLUGIN_LDFLAGS)
89
80 90
81libgnunet_plugin_ats_mlp_la_SOURCES = \ 91libgnunet_plugin_ats_mlp_la_SOURCES = \
82 plugin_ats_mlp.c 92 plugin_ats_mlp.c
@@ -186,7 +196,8 @@ test_ats_api_mlp_LDADD = \
186 libgnunetats.la 196 libgnunetats.la
187 197
188EXTRA_DIST = \ 198EXTRA_DIST = \
189 ats.h \ 199 ats.h ats2.h \
200 plugin_ats2_common.c \
190 test_delay \ 201 test_delay \
191 test_ats_api_mlp.conf \ 202 test_ats_api_mlp.conf \
192 test_ats_api_ril.conf \ 203 test_ats_api_ril.conf \