aboutsummaryrefslogtreecommitdiff
path: root/src/ats/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2015-01-16 10:15:42 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2015-01-16 10:15:42 +0000
commitab3bb8c4287493e878d91882c0cbc132b2b391e7 (patch)
treefa2532fcc5cc88394e7569de9d4e88e333daa5b2 /src/ats/Makefile.am
parentd345f2161a4c7c925ae541d6d76086afc82a245a (diff)
downloadgnunet-ab3bb8c4287493e878d91882c0cbc132b2b391e7.tar.gz
gnunet-ab3bb8c4287493e878d91882c0cbc132b2b391e7.zip
new testcase to test delayed ATS service startup
Diffstat (limited to 'src/ats/Makefile.am')
-rw-r--r--src/ats/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/ats/Makefile.am b/src/ats/Makefile.am
index c6e7c186d..7f91060eb 100644
--- a/src/ats/Makefile.am
+++ b/src/ats/Makefile.am
@@ -117,7 +117,9 @@ TESTING_TESTS = \
117 test_ats_api_scheduling_destroy_address_twice \ 117 test_ats_api_scheduling_destroy_address_twice \
118 test_ats_api_scheduling_add_session \ 118 test_ats_api_scheduling_add_session \
119 test_ats_api_scheduling_destroy_session \ 119 test_ats_api_scheduling_destroy_session \
120 test_ats_api_delayed_service_scheduling_add_address \
120 test_ats_api_performance_list_all_addresses \ 121 test_ats_api_performance_list_all_addresses \
122 test_ats_api_delayed_service_performance_list_all_addresses \
121 test_ats_api_performance_list_peer_addresses \ 123 test_ats_api_performance_list_peer_addresses \
122 test_ats_api_performance_list_all_addresses_active \ 124 test_ats_api_performance_list_all_addresses_active \
123 test_ats_api_performance_monitor \ 125 test_ats_api_performance_monitor \
@@ -173,6 +175,15 @@ test_ats_api_scheduling_add_address_LDADD = \
173 libgnunetats.la \ 175 libgnunetats.la \
174 $(top_builddir)/src/statistics/libgnunetstatistics.la 176 $(top_builddir)/src/statistics/libgnunetstatistics.la
175 177
178test_ats_api_delayed_service_scheduling_add_address_SOURCES = \
179 test_ats_api_delayed_service_scheduling_add_address.c \
180 test_ats_api_common.c test_ats_api_common.h
181test_ats_api_delayed_service_scheduling_add_address_LDADD = \
182 $(top_builddir)/src/util/libgnunetutil.la \
183 $(top_builddir)/src/testing/libgnunettesting.la \
184 libgnunetats.la \
185 $(top_builddir)/src/statistics/libgnunetstatistics.la
186
176test_ats_api_scheduling_add_address_inbound_SOURCES = \ 187test_ats_api_scheduling_add_address_inbound_SOURCES = \
177 test_ats_api_scheduling_add_address_inbound.c \ 188 test_ats_api_scheduling_add_address_inbound.c \
178 test_ats_api_common.c test_ats_api_common.h 189 test_ats_api_common.c test_ats_api_common.h
@@ -235,6 +246,15 @@ test_ats_api_performance_list_all_addresses_LDADD = \
235 $(top_builddir)/src/hello/libgnunethello.la \ 246 $(top_builddir)/src/hello/libgnunethello.la \
236 libgnunetats.la \ 247 libgnunetats.la \
237 $(top_builddir)/src/statistics/libgnunetstatistics.la 248 $(top_builddir)/src/statistics/libgnunetstatistics.la
249
250test_ats_api_delayed_service_performance_list_all_addresses_SOURCES = \
251 test_ats_api_delayed_service_performance_list_all_addresses.c
252test_ats_api_delayed_service_performance_list_all_addresses_LDADD = \
253 $(top_builddir)/src/util/libgnunetutil.la \
254 $(top_builddir)/src/testing/libgnunettesting.la \
255 $(top_builddir)/src/hello/libgnunethello.la \
256 libgnunetats.la \
257 $(top_builddir)/src/statistics/libgnunetstatistics.la
238 258
239test_ats_api_performance_list_peer_addresses_SOURCES = \ 259test_ats_api_performance_list_peer_addresses_SOURCES = \
240 test_ats_api_performance_list_peer_addresses.c 260 test_ats_api_performance_list_peer_addresses.c
@@ -500,7 +520,9 @@ test_ats_solver_preferences_ril_LDADD = \
500 520
501EXTRA_DIST = \ 521EXTRA_DIST = \
502 ats.h \ 522 ats.h \
523 test_delay \
503 test_ats_api.conf \ 524 test_ats_api.conf \
525 test_ats_api_delayed.conf \
504 test_ats_mlp.conf \ 526 test_ats_mlp.conf \
505 test_ats_solver_default.conf \ 527 test_ats_solver_default.conf \
506 test_ats_solver_proportional.conf \ 528 test_ats_solver_proportional.conf \