summaryrefslogtreecommitdiff
path: root/src/ats/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-10-08 16:37:47 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-10-08 16:37:47 +0000
commit045bc5be4f794b863b334a41c126c222c5af6c3c (patch)
treef741b930da60ab912bdd3ba0c99ddce38902d735 /src/ats/Makefile.am
parent8929c943f1f57aaf48a1bc3f6edc9939698e688b (diff)
downloadgnunet-045bc5be4f794b863b334a41c126c222c5af6c3c.tar.gz
gnunet-045bc5be4f794b863b334a41c126c222c5af6c3c.zip
fixes to makefile
Diffstat (limited to 'src/ats/Makefile.am')
-rw-r--r--src/ats/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/ats/Makefile.am b/src/ats/Makefile.am
index b86c53724..fd2156213 100644
--- a/src/ats/Makefile.am
+++ b/src/ats/Makefile.am
@@ -29,18 +29,17 @@ if HAVE_LIBGLPK
29 GN_MLP_REQUEST_ADD_ADDRESS = test_ats_solver_request_and_add_address_mlp 29 GN_MLP_REQUEST_ADD_ADDRESS = test_ats_solver_request_and_add_address_mlp
30 GN_MLP_REQUEST_DELETE_ADDRESS = test_ats_solver_request_and_delete_address_mlp 30 GN_MLP_REQUEST_DELETE_ADDRESS = test_ats_solver_request_and_delete_address_mlp
31 GN_MLP_ALTERNATIVE_DELETE_ADDRESS = test_ats_solver_alternative_after_delete_address_mlp 31 GN_MLP_ALTERNATIVE_DELETE_ADDRESS = test_ats_solver_alternative_after_delete_address_mlp
32
33endif 32endif
34 33
35lib_LTLIBRARIES = libgnunetats.la 34lib_LTLIBRARIES = libgnunetats.la
36 35
37plugin_LTLIBRARIES = \ 36plugin_LTLIBRARIES = \
38 libgnunet_plugin_ats_proportional.la \ 37 libgnunet_plugin_ats_proportional.la \
39 libgnunet_plugin_ats_mlp.la 38 $(GN_MLP_LIB)
40 39
41libgnunetats_la_SOURCES = \ 40libgnunetats_la_SOURCES = \
42 ats_api_scheduling.c \ 41 ats_api_scheduling.c \
43 ats_api_performance.c 42 ats_api_performance.c
44 43
45libgnunetats_la_LIBADD = \ 44libgnunetats_la_LIBADD = \
46 $(top_builddir)/src/util/libgnunetutil.la \ 45 $(top_builddir)/src/util/libgnunetutil.la \
@@ -135,7 +134,6 @@ libgnunet_plugin_ats_proportional_la_LIBADD = \
135 $(LTLIBINTL) 134 $(LTLIBINTL)
136 135
137if HAVE_LIBGLPK 136if HAVE_LIBGLPK
138endif
139libgnunet_plugin_ats_mlp_la_SOURCES = \ 137libgnunet_plugin_ats_mlp_la_SOURCES = \
140 libgnunet_plugin_ats_mlp.c 138 libgnunet_plugin_ats_mlp.c
141libgnunet_plugin_ats_mlp_la_LIBADD = \ 139libgnunet_plugin_ats_mlp_la_LIBADD = \
@@ -144,7 +142,7 @@ libgnunet_plugin_ats_mlp_la_LIBADD = \
144 $(GN_LIBGLPK) 142 $(GN_LIBGLPK)
145libgnunet_plugin_ats_mlp_la_LDFLAGS = \ 143libgnunet_plugin_ats_mlp_la_LDFLAGS = \
146 $(GN_LIBGLPK) 144 $(GN_LIBGLPK)
147 145endif
148 146
149# scheduling API tests 147# scheduling API tests
150 148