aboutsummaryrefslogtreecommitdiff
path: root/src/ats/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-01-18 12:24:15 +0000
committerChristian Grothoff <christian@grothoff.org>2015-01-18 12:24:15 +0000
commit0faae7b9f8d646f42a3a404bea9e86313cb3ec31 (patch)
treeb5cbf7ee49e4fe00d7cddac3a0012cacf0efa384 /src/ats/Makefile.am
parent58e7d98695853ef182f7f7a4c70fefc834aed8ae (diff)
downloadgnunet-0faae7b9f8d646f42a3a404bea9e86313cb3ec31.tar.gz
gnunet-0faae7b9f8d646f42a3a404bea9e86313cb3ec31.zip
-doxygen, link against libgnunethello
Diffstat (limited to 'src/ats/Makefile.am')
-rw-r--r--src/ats/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/ats/Makefile.am b/src/ats/Makefile.am
index 2ed2f4694..ea631709c 100644
--- a/src/ats/Makefile.am
+++ b/src/ats/Makefile.am
@@ -54,6 +54,7 @@ libgnunetats_la_SOURCES = \
54 ats_api_scheduling.c \ 54 ats_api_scheduling.c \
55 ats_api_performance.c 55 ats_api_performance.c
56libgnunetats_la_LIBADD = \ 56libgnunetats_la_LIBADD = \
57 $(top_builddir)/src/hello/libgnunethello.la \
57 $(top_builddir)/src/util/libgnunetutil.la \ 58 $(top_builddir)/src/util/libgnunetutil.la \
58 $(LTLIBINTL) 59 $(LTLIBINTL)
59libgnunetats_la_LDFLAGS = \ 60libgnunetats_la_LDFLAGS = \
@@ -251,7 +252,7 @@ test_ats_api_performance_list_all_addresses_LDADD = \
251 $(top_builddir)/src/hello/libgnunethello.la \ 252 $(top_builddir)/src/hello/libgnunethello.la \
252 libgnunetats.la \ 253 libgnunetats.la \
253 $(top_builddir)/src/statistics/libgnunetstatistics.la 254 $(top_builddir)/src/statistics/libgnunetstatistics.la
254 255
255test_ats_api_delayed_service_performance_list_all_addresses_SOURCES = \ 256test_ats_api_delayed_service_performance_list_all_addresses_SOURCES = \
256 test_ats_api_delayed_service_performance_list_all_addresses.c 257 test_ats_api_delayed_service_performance_list_all_addresses.c
257test_ats_api_delayed_service_performance_list_all_addresses_LDADD = \ 258test_ats_api_delayed_service_performance_list_all_addresses_LDADD = \
@@ -259,7 +260,7 @@ test_ats_api_delayed_service_performance_list_all_addresses_LDADD = \
259 $(top_builddir)/src/testing/libgnunettesting.la \ 260 $(top_builddir)/src/testing/libgnunettesting.la \
260 $(top_builddir)/src/hello/libgnunethello.la \ 261 $(top_builddir)/src/hello/libgnunethello.la \
261 libgnunetats.la \ 262 libgnunetats.la \
262 $(top_builddir)/src/statistics/libgnunetstatistics.la 263 $(top_builddir)/src/statistics/libgnunetstatistics.la
263 264
264test_ats_api_performance_list_peer_addresses_SOURCES = \ 265test_ats_api_performance_list_peer_addresses_SOURCES = \
265 test_ats_api_performance_list_peer_addresses.c 266 test_ats_api_performance_list_peer_addresses.c
@@ -360,7 +361,7 @@ test_ats_solver_add_address_and_request_delayed_proportional_LDADD = \
360 $(top_builddir)/src/hello/libgnunethello.la \ 361 $(top_builddir)/src/hello/libgnunethello.la \
361 libgnunetats.la \ 362 libgnunetats.la \
362 $(top_builddir)/src/statistics/libgnunetstatistics.la 363 $(top_builddir)/src/statistics/libgnunetstatistics.la
363 364
364test_ats_solver_add_address_and_request_delayed_ril_SOURCES = \ 365test_ats_solver_add_address_and_request_delayed_ril_SOURCES = \
365 test_ats_solver_add_address_and_request.c \ 366 test_ats_solver_add_address_and_request.c \
366 test_ats_api_common.c test_ats_api_common.h 367 test_ats_api_common.c test_ats_api_common.h
@@ -369,7 +370,7 @@ test_ats_solver_add_address_and_request_delayed_ril_LDADD = \
369 $(top_builddir)/src/testing/libgnunettesting.la \ 370 $(top_builddir)/src/testing/libgnunettesting.la \
370 $(top_builddir)/src/hello/libgnunethello.la \ 371 $(top_builddir)/src/hello/libgnunethello.la \
371 libgnunetats.la \ 372 libgnunetats.la \
372 $(top_builddir)/src/statistics/libgnunetstatistics.la 373 $(top_builddir)/src/statistics/libgnunetstatistics.la
373 374
374if HAVE_LIBGLPK 375if HAVE_LIBGLPK
375test_ats_solver_add_address_and_request_mlp_SOURCES = \ 376test_ats_solver_add_address_and_request_mlp_SOURCES = \
@@ -391,7 +392,7 @@ test_ats_solver_add_address_and_request_delayed_mlp_LDADD = \
391 $(top_builddir)/src/testing/libgnunettesting.la \ 392 $(top_builddir)/src/testing/libgnunettesting.la \
392 $(top_builddir)/src/hello/libgnunethello.la \ 393 $(top_builddir)/src/hello/libgnunethello.la \
393 libgnunetats.la \ 394 libgnunetats.la \
394 $(top_builddir)/src/statistics/libgnunetstatistics.la 395 $(top_builddir)/src/statistics/libgnunetstatistics.la
395 396
396test_ats_solver_add_address_and_request_ril_SOURCES = \ 397test_ats_solver_add_address_and_request_ril_SOURCES = \
397 test_ats_solver_add_address_and_request.c \ 398 test_ats_solver_add_address_and_request.c \