aboutsummaryrefslogtreecommitdiff
path: root/src/ats/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-02-11 17:10:31 +0000
committerChristian Grothoff <christian@grothoff.org>2015-02-11 17:10:31 +0000
commit81defaa37bf4211f443f74384944642030807018 (patch)
tree7487470c9a7523644f53f6fb9a5f92ba5d2af8c1 /src/ats/Makefile.am
parent9e8d96ae528a7bc3e38d212129ee63727a21d612 (diff)
downloadgnunet-81defaa37bf4211f443f74384944642030807018.tar.gz
gnunet-81defaa37bf4211f443f74384944642030807018.zip
add proper test for bandwidth reservation
Diffstat (limited to 'src/ats/Makefile.am')
-rw-r--r--src/ats/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/ats/Makefile.am b/src/ats/Makefile.am
index 63917b907..cdefaba70 100644
--- a/src/ats/Makefile.am
+++ b/src/ats/Makefile.am
@@ -99,6 +99,7 @@ gnunet_service_ats_LDADD = \
99if HAVE_TESTING 99if HAVE_TESTING
100TESTING_TESTS = \ 100TESTING_TESTS = \
101 test_ats_api_proportional \ 101 test_ats_api_proportional \
102 test_ats_reservation_api_proportional \
102 test_ats_api_ril 103 test_ats_api_ril
103if HAVE_LIBGLPK 104if HAVE_LIBGLPK
104TESTING_TESTS += \ 105TESTING_TESTS += \
@@ -123,6 +124,15 @@ test_ats_api_proportional_LDADD = \
123 $(top_builddir)/src/testing/libgnunettesting.la \ 124 $(top_builddir)/src/testing/libgnunettesting.la \
124 libgnunetats.la 125 libgnunetats.la
125 126
127test_ats_reservation_api_proportional_SOURCES = \
128 test_ats_reservation_api.c \
129 test_ats_lib.c test_ats_lib.h
130test_ats_reservation_api_proportional_LDADD = \
131 $(top_builddir)/src/util/libgnunetutil.la \
132 $(top_builddir)/src/hello/libgnunethello.la \
133 $(top_builddir)/src/testing/libgnunettesting.la \
134 libgnunetats.la
135
126test_ats_api_ril_SOURCES = \ 136test_ats_api_ril_SOURCES = \
127 test_ats_api.c \ 137 test_ats_api.c \
128 test_ats_lib.c test_ats_lib.h 138 test_ats_lib.c test_ats_lib.h