aboutsummaryrefslogtreecommitdiff
path: root/src/ats/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2015-01-16 11:39:16 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2015-01-16 11:39:16 +0000
commit8e234654d3dbcc594f29dcc6ccfbecb743e32246 (patch)
treec1af983d1c194d672a985e05d0f20b9c8198b032 /src/ats/Makefile.am
parent33ca6599024c899501e455bf53153788180c12ac (diff)
downloadgnunet-8e234654d3dbcc594f29dcc6ccfbecb743e32246.tar.gz
gnunet-8e234654d3dbcc594f29dcc6ccfbecb743e32246.zip
test for solvers to support delayed start
Diffstat (limited to 'src/ats/Makefile.am')
-rw-r--r--src/ats/Makefile.am40
1 files changed, 39 insertions, 1 deletions
diff --git a/src/ats/Makefile.am b/src/ats/Makefile.am
index e7396358f..2ed2f4694 100644
--- a/src/ats/Makefile.am
+++ b/src/ats/Makefile.am
@@ -26,6 +26,7 @@ if HAVE_LIBGLPK
26 GN_MLP_PERF = perf_ats_mlp 26 GN_MLP_PERF = perf_ats_mlp
27 GN_MLP_ADD_ADDRESS = test_ats_solver_add_address_mlp 27 GN_MLP_ADD_ADDRESS = test_ats_solver_add_address_mlp
28 GN_MLP_ADD_REQUEST_ADDRESS = test_ats_solver_add_address_and_request_mlp 28 GN_MLP_ADD_REQUEST_ADDRESS = test_ats_solver_add_address_and_request_mlp
29 GN_MLP_ADD_REQUEST_ADDRESS_DELAYED = test_ats_solver_add_address_and_request_delayed_mlp
29 GN_MLP_REQUEST_ADD_ADDRESS = test_ats_solver_request_and_add_address_mlp 30 GN_MLP_REQUEST_ADD_ADDRESS = test_ats_solver_request_and_add_address_mlp
30 GN_MLP_REQUEST_DELETE_ADDRESS = test_ats_solver_request_and_delete_address_mlp 31 GN_MLP_REQUEST_DELETE_ADDRESS = test_ats_solver_request_and_delete_address_mlp
31 GN_MLP_PREFERENCES_ADDRESS = test_ats_solver_preferences_mlp 32 GN_MLP_PREFERENCES_ADDRESS = test_ats_solver_preferences_mlp
@@ -123,10 +124,11 @@ TESTING_TESTS = \
123 test_ats_api_performance_list_peer_addresses \ 124 test_ats_api_performance_list_peer_addresses \
124 test_ats_api_performance_list_all_addresses_active \ 125 test_ats_api_performance_list_all_addresses_active \
125 test_ats_api_performance_monitor \ 126 test_ats_api_performance_monitor \
126 test_ats_api_delayed_service_performance_monitor\ 127 test_ats_api_delayed_service_performance_monitor \
127 test_ats_api_performance_monitor_initial_callback \ 128 test_ats_api_performance_monitor_initial_callback \
128 test_ats_solver_add_address_proportional \ 129 test_ats_solver_add_address_proportional \
129 test_ats_solver_add_address_and_request_proportional \ 130 test_ats_solver_add_address_and_request_proportional \
131 test_ats_solver_add_address_and_request_delayed_proportional\
130 test_ats_solver_request_and_add_address_proportional \ 132 test_ats_solver_request_and_add_address_proportional \
131 test_ats_solver_request_and_delete_address_proportional \ 133 test_ats_solver_request_and_delete_address_proportional \
132 test_ats_solver_alternative_after_delete_address_proportional \ 134 test_ats_solver_alternative_after_delete_address_proportional \
@@ -134,12 +136,14 @@ TESTING_TESTS = \
134 test_ats_solver_preferences_ril \ 136 test_ats_solver_preferences_ril \
135 $(GN_MLP_ADD_ADDRESS) \ 137 $(GN_MLP_ADD_ADDRESS) \
136 $(GN_MLP_ADD_REQUEST_ADDRESS) \ 138 $(GN_MLP_ADD_REQUEST_ADDRESS) \
139 $(GN_MLP_ADD_REQUEST_ADDRESS_DELAYED) \
137 $(GN_MLP_REQUEST_ADD_ADDRESS) \ 140 $(GN_MLP_REQUEST_ADD_ADDRESS) \
138 $(GN_MLP_REQUEST_DELETE_ADDRESS) \ 141 $(GN_MLP_REQUEST_DELETE_ADDRESS) \
139 $(GN_MLP_ALTERNATIVE_DELETE_ADDRESS) \ 142 $(GN_MLP_ALTERNATIVE_DELETE_ADDRESS) \
140 $(GN_MLP_PREFERENCES_ADDRESS) \ 143 $(GN_MLP_PREFERENCES_ADDRESS) \
141 test_ats_solver_add_address_ril \ 144 test_ats_solver_add_address_ril \
142 test_ats_solver_add_address_and_request_ril \ 145 test_ats_solver_add_address_and_request_ril \
146 test_ats_solver_add_address_and_request_delayed_ril \
143 test_ats_solver_request_and_add_address_ril \ 147 test_ats_solver_request_and_add_address_ril \
144 test_ats_solver_request_and_delete_address_ril \ 148 test_ats_solver_request_and_delete_address_ril \
145 test_ats_solver_alternative_after_delete_address_ril \ 149 test_ats_solver_alternative_after_delete_address_ril \
@@ -347,6 +351,26 @@ test_ats_solver_add_address_and_request_proportional_LDADD = \
347 libgnunetats.la \ 351 libgnunetats.la \
348 $(top_builddir)/src/statistics/libgnunetstatistics.la 352 $(top_builddir)/src/statistics/libgnunetstatistics.la
349 353
354test_ats_solver_add_address_and_request_delayed_proportional_SOURCES = \
355 test_ats_solver_add_address_and_request.c \
356 test_ats_api_common.c test_ats_api_common.h
357test_ats_solver_add_address_and_request_delayed_proportional_LDADD = \
358 $(top_builddir)/src/util/libgnunetutil.la \
359 $(top_builddir)/src/testing/libgnunettesting.la \
360 $(top_builddir)/src/hello/libgnunethello.la \
361 libgnunetats.la \
362 $(top_builddir)/src/statistics/libgnunetstatistics.la
363
364test_ats_solver_add_address_and_request_delayed_ril_SOURCES = \
365 test_ats_solver_add_address_and_request.c \
366 test_ats_api_common.c test_ats_api_common.h
367test_ats_solver_add_address_and_request_delayed_ril_LDADD = \
368 $(top_builddir)/src/util/libgnunetutil.la \
369 $(top_builddir)/src/testing/libgnunettesting.la \
370 $(top_builddir)/src/hello/libgnunethello.la \
371 libgnunetats.la \
372 $(top_builddir)/src/statistics/libgnunetstatistics.la
373
350if HAVE_LIBGLPK 374if HAVE_LIBGLPK
351test_ats_solver_add_address_and_request_mlp_SOURCES = \ 375test_ats_solver_add_address_and_request_mlp_SOURCES = \
352 test_ats_solver_add_address_and_request.c \ 376 test_ats_solver_add_address_and_request.c \
@@ -359,6 +383,16 @@ test_ats_solver_add_address_and_request_mlp_LDADD = \
359 $(top_builddir)/src/statistics/libgnunetstatistics.la 383 $(top_builddir)/src/statistics/libgnunetstatistics.la
360endif 384endif
361 385
386test_ats_solver_add_address_and_request_delayed_mlp_SOURCES = \
387 test_ats_solver_add_address_and_request.c \
388 test_ats_api_common.c test_ats_api_common.h
389test_ats_solver_add_address_and_request_delayed_mlp_LDADD = \
390 $(top_builddir)/src/util/libgnunetutil.la \
391 $(top_builddir)/src/testing/libgnunettesting.la \
392 $(top_builddir)/src/hello/libgnunethello.la \
393 libgnunetats.la \
394 $(top_builddir)/src/statistics/libgnunetstatistics.la
395
362test_ats_solver_add_address_and_request_ril_SOURCES = \ 396test_ats_solver_add_address_and_request_ril_SOURCES = \
363 test_ats_solver_add_address_and_request.c \ 397 test_ats_solver_add_address_and_request.c \
364 test_ats_api_common.c test_ats_api_common.h 398 test_ats_api_common.c test_ats_api_common.h
@@ -538,9 +572,13 @@ EXTRA_DIST = \
538 test_ats_mlp.conf \ 572 test_ats_mlp.conf \
539 test_ats_solver_default.conf \ 573 test_ats_solver_default.conf \
540 test_ats_solver_proportional.conf \ 574 test_ats_solver_proportional.conf \
575 test_ats_solver_proportional.conf \
541 test_ats_solver_mlp.conf \ 576 test_ats_solver_mlp.conf \
577 test_ats_solver_delayed_mlp.conf \
542 test_ats_solver_ril.conf \ 578 test_ats_solver_ril.conf \
579 test_ats_solver_delayed_ril.conf \
543 perf_ats_solver_mlp.conf \ 580 perf_ats_solver_mlp.conf \
581 test_ats_solver_delayed_mlp.conf \
544 perf_ats_solver_proportional.conf \ 582 perf_ats_solver_proportional.conf \
545 perf_ats_solver_ril.conf \ 583 perf_ats_solver_ril.conf \
546 perf_ats_solver.conf 584 perf_ats_solver.conf