aboutsummaryrefslogtreecommitdiff
path: root/src/block/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-02-20 15:09:00 +0100
committerChristian Grothoff <christian@grothoff.org>2017-02-20 15:09:19 +0100
commita3882b58f1c5976677aa65b0af8a48e8e946b06e (patch)
treebd841d8e78052a05821e194d002ca843693fb2c9 /src/block/Makefile.am
parentf0149c5430f42a8bad422e9c51754af59c7bfa2f (diff)
downloadgnunet-a3882b58f1c5976677aa65b0af8a48e8e946b06e.tar.gz
gnunet-a3882b58f1c5976677aa65b0af8a48e8e946b06e.zip
first half of new BLOCK API to generalize duplicate detection beyond BFs
Diffstat (limited to 'src/block/Makefile.am')
-rw-r--r--src/block/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/block/Makefile.am b/src/block/Makefile.am
index c54a4c246..4a6d8e71e 100644
--- a/src/block/Makefile.am
+++ b/src/block/Makefile.am
@@ -11,7 +11,9 @@ if USE_COVERAGE
11 AM_CFLAGS = --coverage 11 AM_CFLAGS = --coverage
12endif 12endif
13 13
14lib_LTLIBRARIES = libgnunetblock.la 14lib_LTLIBRARIES = \
15 libgnunetblock.la \
16 libgnunetblockgroup.la
15 17
16plugin_LTLIBRARIES = \ 18plugin_LTLIBRARIES = \
17 libgnunet_plugin_block_test.la 19 libgnunet_plugin_block_test.la
@@ -49,3 +51,14 @@ libgnunetblock_la_DEPENDENCIES = \
49libgnunetblock_la_LDFLAGS = \ 51libgnunetblock_la_LDFLAGS = \
50 $(GN_LIB_LDFLAGS) \ 52 $(GN_LIB_LDFLAGS) \
51 -version-info 0:0:0 53 -version-info 0:0:0
54
55
56libgnunetblockgroup_la_SOURCES = \
57 bg_bf.c
58libgnunetblockgroup_la_LIBADD = \
59 $(top_builddir)/src/util/libgnunetutil.la
60libgnunetblockgroup_la_DEPENDENCIES = \
61 $(top_builddir)/src/util/libgnunetutil.la
62libgnunetblockgroup_la_LDFLAGS = \
63 $(GN_LIB_LDFLAGS) \
64 -version-info 0:0:0