aboutsummaryrefslogtreecommitdiff
path: root/src/block/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2010-04-24 13:46:07 +0000
committerChristian Grothoff <christian@grothoff.org>2010-04-24 13:46:07 +0000
commit8d9525a642c6bd74a2903ccb6358da8ebb081864 (patch)
tree1e26db482e5ab9869bbc5cc687e1cd27c592eda6 /src/block/Makefile.am
parent32892c4aa7736eb8039f28d79b5cdb53cdc0061c (diff)
downloadgnunet-8d9525a642c6bd74a2903ccb6358da8ebb081864.tar.gz
gnunet-8d9525a642c6bd74a2903ccb6358da8ebb081864.zip
blocklib
Diffstat (limited to 'src/block/Makefile.am')
-rw-r--r--src/block/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/block/Makefile.am b/src/block/Makefile.am
new file mode 100644
index 000000000..b9585c260
--- /dev/null
+++ b/src/block/Makefile.am
@@ -0,0 +1,28 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage
9endif
10
11lib_LTLIBRARIES = libgnunetblock.la
12
13libgnunetblock_la_SOURCES = \
14 block.c
15libgnunetblock_la_LIBADD = \
16 $(top_builddir)/src/util/libgnunetutil.la
17
18check_PROGRAMS = \
19 test_block
20
21#TESTS = $(check_PROGRAMS)
22
23test_block_SOURCES = \
24 test_block.c
25test_block_LDADD = \
26 $(top_builddir)/src/block/libgnunetblock.la \
27 $(top_builddir)/src/util/libgnunetutil.la
28