aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorPhilipp Tölke <toelke@in.tum.de>2011-01-05 15:37:07 +0000
committerPhilipp Tölke <toelke@in.tum.de>2011-01-05 15:37:07 +0000
commit1c930a3459ca5875bc9fc93cf4761f570e02c701 (patch)
tree04914c680f68c94dba91a056dd013904bc9d66cf /src/core/Makefile.am
parent6d3e206b41bee6ed6443c81874c39b872b1f04bc (diff)
downloadgnunet-1c930a3459ca5875bc9fc93cf4761f570e02c701.tar.gz
gnunet-1c930a3459ca5875bc9fc93cf4761f570e02c701.zip
test-case for cores send-to-self-feature
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index f4844b8ee..e8d836717 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -25,7 +25,7 @@ libgnunetcore_la_LDFLAGS = \
25 25
26 26
27bin_PROGRAMS = \ 27bin_PROGRAMS = \
28 gnunet-service-core 28 gnunet-service-core test_core_api_send_to_self
29 29
30gnunet_service_core_SOURCES = \ 30gnunet_service_core_SOURCES = \
31 gnunet-service-core.c 31 gnunet-service-core.c
@@ -43,7 +43,8 @@ check_PROGRAMS = \
43 test_core_api_reliability \ 43 test_core_api_reliability \
44 test_core_quota_compliance_symmetric \ 44 test_core_quota_compliance_symmetric \
45 test_core_quota_compliance_asymmetric_send_limited \ 45 test_core_quota_compliance_asymmetric_send_limited \
46 test_core_quota_compliance_asymmetric_recv_limited 46 test_core_quota_compliance_asymmetric_recv_limited \
47 test_core_api_send_to_self
47 48
48if !DISABLE_TEST_RUN 49if !DISABLE_TEST_RUN
49TESTS = $(check_PROGRAMS) 50TESTS = $(check_PROGRAMS)
@@ -63,6 +64,13 @@ test_core_api_reliability_LDADD = \
63 $(top_builddir)/src/transport/libgnunettransport.la \ 64 $(top_builddir)/src/transport/libgnunettransport.la \
64 $(top_builddir)/src/util/libgnunetutil.la 65 $(top_builddir)/src/util/libgnunetutil.la
65 66
67test_core_api_send_to_self_SOURCES = \
68 test_core_api_send_to_self.c
69test_core_api_send_to_self_LDADD = \
70 $(top_builddir)/src/core/libgnunetcore.la \
71 $(top_builddir)/src/transport/libgnunettransport.la \
72 $(top_builddir)/src/util/libgnunetutil.la
73
66test_core_api_start_only_SOURCES = \ 74test_core_api_start_only_SOURCES = \
67 test_core_api_start_only.c 75 test_core_api_start_only.c
68test_core_api_start_only_LDADD = \ 76test_core_api_start_only_LDADD = \