summaryrefslogtreecommitdiff
path: root/src/credential/Makefile.am
diff options
context:
space:
mode:
authorAndreas Ebner <pansy007@googlemail.com>2019-07-07 15:04:40 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-10-07 12:15:06 +0200
commitfc58d9d4241ed2dcd4b492b4f922ba959449a697 (patch)
tree812713718d2d93d70a3ee1a22b20d55e65969873 /src/credential/Makefile.am
parentd2634b1f96dfd55ae4daef294bb6c05d687354c8 (diff)
downloadgnunet-fc58d9d4241ed2dcd4b492b4f922ba959449a697.tar.gz
gnunet-fc58d9d4241ed2dcd4b492b4f922ba959449a697.zip
Implemented delegate sign and store function for GNS entries:
- functions to store and sign delegates (all types) including serialization/string_to_value/.. - solved (almost) all TODOs - some renaming and cleanup in gnunet-credential.c - valgrind checked - test file adapted accordingly
Diffstat (limited to 'src/credential/Makefile.am')
-rw-r--r--src/credential/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/credential/Makefile.am b/src/credential/Makefile.am
index 5b14b3def..7d9ab4bea 100644
--- a/src/credential/Makefile.am
+++ b/src/credential/Makefile.am
@@ -69,11 +69,13 @@ gnunet_service_credential_LDADD = \
69 69
70 70
71libgnunetcredential_la_SOURCES = \ 71libgnunetcredential_la_SOURCES = \
72 credential_api.c credential.h \ 72 credential_api.c credential.h deleagte.h\
73 credential_serialization.c \ 73 credential_serialization.c \
74 credential_serialization.h \ 74 credential_serialization.h \
75 credential_misc.c \ 75 credential_misc.c \
76 credential_misc.h 76 credential_misc.h \
77 delegate_misc.c \
78 delegate_misc.h
77libgnunetcredential_la_LIBADD = \ 79libgnunetcredential_la_LIBADD = \
78 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) 80 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
79libgnunetcredential_la_LDFLAGS = \ 81libgnunetcredential_la_LDFLAGS = \