aboutsummaryrefslogtreecommitdiff
path: root/src/curl/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-04-17 15:09:23 +0000
committerChristian Grothoff <christian@grothoff.org>2016-04-17 15:09:23 +0000
commit16642c4cb25faae335591b39795c71dedbeb37f1 (patch)
tree99eced0e91cb1455f4dc5afd1fd3918259aa5dd3 /src/curl/Makefile.am
parentda7b8273d9f2229fe163ef4fbdcf046fb6227b73 (diff)
downloadgnunet-16642c4cb25faae335591b39795c71dedbeb37f1.tar.gz
gnunet-16642c4cb25faae335591b39795c71dedbeb37f1.zip
adding libgnunetcurl
Diffstat (limited to 'src/curl/Makefile.am')
-rw-r--r--src/curl/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/curl/Makefile.am b/src/curl/Makefile.am
new file mode 100644
index 000000000..4bdd03039
--- /dev/null
+++ b/src/curl/Makefile.am
@@ -0,0 +1,33 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9lib_LTLIBRARIES = \
10 libgnunetcurl.la
11
12libgnunetcurl_la_LDFLAGS = \
13 -version-info 0:0:0 \
14 -no-undefined
15libgnunetcurl_la_SOURCES = \
16 curl.c
17libgnunetcurl_la_LIBADD = \
18 $(top_builddir)/src/util/libgnunetutil.la \
19 -ljansson \
20 $(XLIB)
21
22#check_PROGRAMS = \
23# test_curl
24
25#TESTS = \
26# $(check_PROGRAMS)
27
28#test_curl_SOURCES = \
29# test_curl.c
30#test_curl_LDADD = \
31# libgnunetcurl.la \
32# $(top_builddir)/src/util/libgnunetutil.la \
33# -ljansson -lcurl