aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-11-13 20:05:40 +0000
committerChristian Grothoff <christian@grothoff.org>2012-11-13 20:05:40 +0000
commit4e1d85bac66209e6655f3fb4d3ddef7929f0f3fc (patch)
treedf5c5a0d972f35d741b51c3a3fc8d2298ac8b4fd /src/datacache/Makefile.am
parent855362e698928b0a5a8f72fc6427c2ea42af4e79 (diff)
downloadgnunet-4e1d85bac66209e6655f3fb4d3ddef7929f0f3fc.tar.gz
gnunet-4e1d85bac66209e6655f3fb4d3ddef7929f0f3fc.zip
changing datacache API to separate put-paths from data (so that plugins can test for duplicates), removing support for MySQL
Diffstat (limited to 'src/datacache/Makefile.am')
-rw-r--r--src/datacache/Makefile.am48
1 files changed, 15 insertions, 33 deletions
diff --git a/src/datacache/Makefile.am b/src/datacache/Makefile.am
index 99e333dc9..c6c27b327 100644
--- a/src/datacache/Makefile.am
+++ b/src/datacache/Makefile.am
@@ -19,9 +19,6 @@ endif
19if HAVE_SQLITE 19if HAVE_SQLITE
20 SQLITE_PLUGIN = libgnunet_plugin_datacache_sqlite.la 20 SQLITE_PLUGIN = libgnunet_plugin_datacache_sqlite.la
21endif 21endif
22if HAVE_MYSQL
23 MYSQL_PLUGIN = libgnunet_plugin_datacache_mysql.la
24endif
25if HAVE_POSTGRES 22if HAVE_POSTGRES
26 POSTGRES_PLUGIN = libgnunet_plugin_datacache_postgres.la 23 POSTGRES_PLUGIN = libgnunet_plugin_datacache_postgres.la
27endif 24endif
@@ -42,7 +39,6 @@ libgnunetdatacache_la_LDFLAGS = \
42 39
43plugin_LTLIBRARIES = \ 40plugin_LTLIBRARIES = \
44 $(SQLITE_PLUGIN) \ 41 $(SQLITE_PLUGIN) \
45 $(MYSQL_PLUGIN) \
46 $(POSTGRES_PLUGIN) \ 42 $(POSTGRES_PLUGIN) \
47 libgnunet_plugin_datacache_heap.la \ 43 libgnunet_plugin_datacache_heap.la \
48 libgnunet_plugin_datacache_template.la 44 libgnunet_plugin_datacache_template.la
@@ -66,18 +62,6 @@ libgnunet_plugin_datacache_heap_la_LIBADD = \
66libgnunet_plugin_datacache_heap_la_LDFLAGS = \ 62libgnunet_plugin_datacache_heap_la_LDFLAGS = \
67 $(GN_PLUGIN_LDFLAGS) 63 $(GN_PLUGIN_LDFLAGS)
68 64
69libgnunet_plugin_datacache_mysql_la_SOURCES = \
70 plugin_datacache_mysql.c
71libgnunet_plugin_datacache_mysql_la_LIBADD = \
72 $(top_builddir)/src/statistics/libgnunetstatistics.la \
73 $(top_builddir)/src/mysql/libgnunetmysql.la \
74 $(top_builddir)/src/util/libgnunetutil.la \
75 $(GN_PLUGIN_LDFLAGS) $(MYSQL_LDFLAGS) -lmysqlclient
76libgnunet_plugin_datacache_mysql_la_CPPFLAGS = \
77 $(MYSQL_CPPFLAGS)
78libgnunet_plugin_datacache_mysql_la_LDFLAGS = \
79 $(GN_PLUGIN_LDFLAGS) $(MYSQL_LDFLAGS) -lmysqlclient
80
81libgnunet_plugin_datacache_postgres_la_SOURCES = \ 65libgnunet_plugin_datacache_postgres_la_SOURCES = \
82 plugin_datacache_postgres.c 66 plugin_datacache_postgres.c
83libgnunet_plugin_datacache_postgres_la_LIBADD = \ 67libgnunet_plugin_datacache_postgres_la_LIBADD = \
@@ -110,16 +94,14 @@ SQLITE_TESTS = \
110 $(SQLITE_BENCHMARKS) 94 $(SQLITE_BENCHMARKS)
111endif 95endif
112 96
113if HAVE_MYSQL
114if HAVE_BENCHMARKS 97if HAVE_BENCHMARKS
115 MYSQL_BENCHMARKS = \ 98 HEAP_BENCHMARKS = \
116 perf_datacache_mysql 99 perf_datacache_heap
117endif
118MYSQL_TESTS = \
119 test_datacache_mysql \
120 test_datacache_quota_mysql \
121 $(MYSQL_BENCHMARKS)
122endif 100endif
101HEAP_TESTS = \
102 test_datacache_heap \
103 test_datacache_quota_heap \
104 $(HEAP_BENCHMARKS)
123 105
124if HAVE_POSTGRES 106if HAVE_POSTGRES
125if HAVE_BENCHMARKS 107if HAVE_BENCHMARKS
@@ -134,7 +116,7 @@ endif
134 116
135check_PROGRAMS = \ 117check_PROGRAMS = \
136 $(SQLITE_TESTS) \ 118 $(SQLITE_TESTS) \
137 $(MYSQL_TESTS) \ 119 $(HEAP_TESTS) \
138 $(POSTGRES_TESTS) 120 $(POSTGRES_TESTS)
139 121
140if ENABLE_TEST_RUN 122if ENABLE_TEST_RUN
@@ -162,23 +144,23 @@ perf_datacache_sqlite_LDADD = \
162 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 144 $(top_builddir)/src/datacache/libgnunetdatacache.la \
163 $(top_builddir)/src/util/libgnunetutil.la 145 $(top_builddir)/src/util/libgnunetutil.la
164 146
165test_datacache_mysql_SOURCES = \ 147test_datacache_heap_SOURCES = \
166 test_datacache.c 148 test_datacache.c
167test_datacache_mysql_LDADD = \ 149test_datacache_heap_LDADD = \
168 $(top_builddir)/src/testing/libgnunettesting.la \ 150 $(top_builddir)/src/testing/libgnunettesting.la \
169 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 151 $(top_builddir)/src/datacache/libgnunetdatacache.la \
170 $(top_builddir)/src/util/libgnunetutil.la 152 $(top_builddir)/src/util/libgnunetutil.la
171 153
172test_datacache_quota_mysql_SOURCES = \ 154test_datacache_quota_heap_SOURCES = \
173 test_datacache_quota.c 155 test_datacache_quota.c
174test_datacache_quota_mysql_LDADD = \ 156test_datacache_quota_heap_LDADD = \
175 $(top_builddir)/src/testing/libgnunettesting.la \ 157 $(top_builddir)/src/testing/libgnunettesting.la \
176 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 158 $(top_builddir)/src/datacache/libgnunetdatacache.la \
177 $(top_builddir)/src/util/libgnunetutil.la 159 $(top_builddir)/src/util/libgnunetutil.la
178 160
179perf_datacache_mysql_SOURCES = \ 161perf_datacache_heap_SOURCES = \
180 perf_datacache.c 162 perf_datacache.c
181perf_datacache_mysql_LDADD = \ 163perf_datacache_heap_LDADD = \
182 $(top_builddir)/src/testing/libgnunettesting.la \ 164 $(top_builddir)/src/testing/libgnunettesting.la \
183 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 165 $(top_builddir)/src/datacache/libgnunetdatacache.la \
184 $(top_builddir)/src/util/libgnunetutil.la 166 $(top_builddir)/src/util/libgnunetutil.la
@@ -207,7 +189,7 @@ perf_datacache_postgres_LDADD = \
207EXTRA_DIST = \ 189EXTRA_DIST = \
208 test_datacache_data_sqlite.conf \ 190 test_datacache_data_sqlite.conf \
209 perf_datacache_data_sqlite.conf \ 191 perf_datacache_data_sqlite.conf \
210 test_datacache_data_mysql.conf \ 192 test_datacache_data_heap.conf \
211 perf_datacache_data_mysql.conf \ 193 perf_datacache_data_heap.conf \
212 test_datacache_data_postgres.conf \ 194 test_datacache_data_postgres.conf \
213 perf_datacache_data_postgres.conf 195 perf_datacache_data_postgres.conf