aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2010-07-28 20:19:39 +0000
committerChristian Grothoff <christian@grothoff.org>2010-07-28 20:19:39 +0000
commit7d719b15594de606dd65d9a93e74a605bb0637f3 (patch)
treecb3cb3d72c3add3dc6068c767159faf15e69c3a1 /src/datacache/Makefile.am
parentd72151f265cb7aacb184c1fbd160d6a323ccd9aa (diff)
downloadgnunet-7d719b15594de606dd65d9a93e74a605bb0637f3.tar.gz
gnunet-7d719b15594de606dd65d9a93e74a605bb0637f3.zip
fixing #1589
Diffstat (limited to 'src/datacache/Makefile.am')
-rw-r--r--src/datacache/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/datacache/Makefile.am b/src/datacache/Makefile.am
index 0713d792d..a10343046 100644
--- a/src/datacache/Makefile.am
+++ b/src/datacache/Makefile.am
@@ -11,6 +11,9 @@ if USE_COVERAGE
11 XLIBS = -lgcov 11 XLIBS = -lgcov
12endif 12endif
13 13
14if HAVE_SQLITE
15 SQLITE_PLUGIN = libgnunet_plugin_datacache_sqlite.la
16endif
14 17
15lib_LTLIBRARIES = \ 18lib_LTLIBRARIES = \
16 libgnunetdatacache.la 19 libgnunetdatacache.la
@@ -27,7 +30,7 @@ libgnunetdatacache_la_LDFLAGS = \
27 30
28 31
29plugin_LTLIBRARIES = \ 32plugin_LTLIBRARIES = \
30 libgnunet_plugin_datacache_sqlite.la \ 33 $(SQLITE_PLUGIN) \
31 libgnunet_plugin_datacache_template.la 34 libgnunet_plugin_datacache_template.la
32 35
33 36
@@ -47,10 +50,14 @@ libgnunet_plugin_datacache_template_la_LDFLAGS = \
47 $(GN_PLUGIN_LDFLAGS) 50 $(GN_PLUGIN_LDFLAGS)
48 51
49 52
50check_PROGRAMS = \ 53if HAVE_SQLITE
54 SQLITE_TESTS = \
51 test_datacache \ 55 test_datacache \
52 test_datacache_quota \ 56 test_datacache_quota \
53 perf_datacache 57 perf_datacache
58endif
59
60check_PROGRAMS = $(SQLITE_TESTS)
54 61
55if !DISABLE_TEST_RUN 62if !DISABLE_TEST_RUN
56TESTS = $(check_PROGRAMS) 63TESTS = $(check_PROGRAMS)