aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-06-10 11:43:20 +0000
committerChristian Grothoff <christian@grothoff.org>2012-06-10 11:43:20 +0000
commitdadbf4c950bf4cd459c95ac4ab61a02af7b3668b (patch)
treeddaf0644dcd97fbef7f67a68eff2a5cf204b0bb7 /src/datacache/Makefile.am
parent8efaae301b29ec7cbdb921ac5e6b30ae2c143568 (diff)
downloadgnunet-dadbf4c950bf4cd459c95ac4ab61a02af7b3668b.tar.gz
gnunet-dadbf4c950bf4cd459c95ac4ab61a02af7b3668b.zip
-using new testing api to determine plugin name
Diffstat (limited to 'src/datacache/Makefile.am')
-rw-r--r--src/datacache/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/datacache/Makefile.am b/src/datacache/Makefile.am
index e1cd8fd79..0f10e6c1b 100644
--- a/src/datacache/Makefile.am
+++ b/src/datacache/Makefile.am
@@ -134,54 +134,63 @@ endif
134test_datacache_sqlite_SOURCES = \ 134test_datacache_sqlite_SOURCES = \
135 test_datacache.c 135 test_datacache.c
136test_datacache_sqlite_LDADD = \ 136test_datacache_sqlite_LDADD = \
137 $(top_builddir)/src/testing/libgnunettesting.la \
137 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 138 $(top_builddir)/src/datacache/libgnunetdatacache.la \
138 $(top_builddir)/src/util/libgnunetutil.la 139 $(top_builddir)/src/util/libgnunetutil.la
139 140
140test_datacache_quota_sqlite_SOURCES = \ 141test_datacache_quota_sqlite_SOURCES = \
141 test_datacache_quota.c 142 test_datacache_quota.c
142test_datacache_quota_sqlite_LDADD = \ 143test_datacache_quota_sqlite_LDADD = \
144 $(top_builddir)/src/testing/libgnunettesting.la \
143 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 145 $(top_builddir)/src/datacache/libgnunetdatacache.la \
144 $(top_builddir)/src/util/libgnunetutil.la 146 $(top_builddir)/src/util/libgnunetutil.la
145 147
146perf_datacache_sqlite_SOURCES = \ 148perf_datacache_sqlite_SOURCES = \
147 perf_datacache.c 149 perf_datacache.c
148perf_datacache_sqlite_LDADD = \ 150perf_datacache_sqlite_LDADD = \
151 $(top_builddir)/src/testing/libgnunettesting.la \
149 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 152 $(top_builddir)/src/datacache/libgnunetdatacache.la \
150 $(top_builddir)/src/util/libgnunetutil.la 153 $(top_builddir)/src/util/libgnunetutil.la
151 154
152test_datacache_mysql_SOURCES = \ 155test_datacache_mysql_SOURCES = \
153 test_datacache.c 156 test_datacache.c
154test_datacache_mysql_LDADD = \ 157test_datacache_mysql_LDADD = \
158 $(top_builddir)/src/testing/libgnunettesting.la \
155 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 159 $(top_builddir)/src/datacache/libgnunetdatacache.la \
156 $(top_builddir)/src/util/libgnunetutil.la 160 $(top_builddir)/src/util/libgnunetutil.la
157 161
158test_datacache_quota_mysql_SOURCES = \ 162test_datacache_quota_mysql_SOURCES = \
159 test_datacache_quota.c 163 test_datacache_quota.c
160test_datacache_quota_mysql_LDADD = \ 164test_datacache_quota_mysql_LDADD = \
165 $(top_builddir)/src/testing/libgnunettesting.la \
161 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 166 $(top_builddir)/src/datacache/libgnunetdatacache.la \
162 $(top_builddir)/src/util/libgnunetutil.la 167 $(top_builddir)/src/util/libgnunetutil.la
163 168
164perf_datacache_mysql_SOURCES = \ 169perf_datacache_mysql_SOURCES = \
165 perf_datacache.c 170 perf_datacache.c
166perf_datacache_mysql_LDADD = \ 171perf_datacache_mysql_LDADD = \
172 $(top_builddir)/src/testing/libgnunettesting.la \
167 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 173 $(top_builddir)/src/datacache/libgnunetdatacache.la \
168 $(top_builddir)/src/util/libgnunetutil.la 174 $(top_builddir)/src/util/libgnunetutil.la
169 175
170test_datacache_postgres_SOURCES = \ 176test_datacache_postgres_SOURCES = \
171 test_datacache.c 177 test_datacache.c
172test_datacache_postgres_LDADD = \ 178test_datacache_postgres_LDADD = \
179 $(top_builddir)/src/testing/libgnunettesting.la \
173 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 180 $(top_builddir)/src/datacache/libgnunetdatacache.la \
174 $(top_builddir)/src/util/libgnunetutil.la 181 $(top_builddir)/src/util/libgnunetutil.la
175 182
176test_datacache_quota_postgres_SOURCES = \ 183test_datacache_quota_postgres_SOURCES = \
177 test_datacache_quota.c 184 test_datacache_quota.c
178test_datacache_quota_postgres_LDADD = \ 185test_datacache_quota_postgres_LDADD = \
186 $(top_builddir)/src/testing/libgnunettesting.la \
179 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 187 $(top_builddir)/src/datacache/libgnunetdatacache.la \
180 $(top_builddir)/src/util/libgnunetutil.la 188 $(top_builddir)/src/util/libgnunetutil.la
181 189
182perf_datacache_postgres_SOURCES = \ 190perf_datacache_postgres_SOURCES = \
183 perf_datacache.c 191 perf_datacache.c
184perf_datacache_postgres_LDADD = \ 192perf_datacache_postgres_LDADD = \
193 $(top_builddir)/src/testing/libgnunettesting.la \
185 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 194 $(top_builddir)/src/datacache/libgnunetdatacache.la \
186 $(top_builddir)/src/util/libgnunetutil.la 195 $(top_builddir)/src/util/libgnunetutil.la
187 196