aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-11-12 14:40:11 +0000
committerChristian Grothoff <christian@grothoff.org>2012-11-12 14:40:11 +0000
commitf397c283914604f4d526e7b9fc438c7ccc56bded (patch)
tree149a834894fa2c436dfa0bfe109dc03f50123c9a /src/datacache/Makefile.am
parent386e076d4958b21dcc100661ec1343054904949a (diff)
downloadgnunet-f397c283914604f4d526e7b9fc438c7ccc56bded.tar.gz
gnunet-f397c283914604f4d526e7b9fc438c7ccc56bded.zip
-adding plugin to keep datacache entirely in the heap
Diffstat (limited to 'src/datacache/Makefile.am')
-rw-r--r--src/datacache/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/datacache/Makefile.am b/src/datacache/Makefile.am
index 0f10e6c1b..99e333dc9 100644
--- a/src/datacache/Makefile.am
+++ b/src/datacache/Makefile.am
@@ -44,6 +44,7 @@ plugin_LTLIBRARIES = \
44 $(SQLITE_PLUGIN) \ 44 $(SQLITE_PLUGIN) \
45 $(MYSQL_PLUGIN) \ 45 $(MYSQL_PLUGIN) \
46 $(POSTGRES_PLUGIN) \ 46 $(POSTGRES_PLUGIN) \
47 libgnunet_plugin_datacache_heap.la \
47 libgnunet_plugin_datacache_template.la 48 libgnunet_plugin_datacache_template.la
48 49
49 50
@@ -56,6 +57,15 @@ libgnunet_plugin_datacache_sqlite_la_LIBADD = \
56libgnunet_plugin_datacache_sqlite_la_LDFLAGS = \ 57libgnunet_plugin_datacache_sqlite_la_LDFLAGS = \
57 $(GN_PLUGIN_LDFLAGS) 58 $(GN_PLUGIN_LDFLAGS)
58 59
60libgnunet_plugin_datacache_heap_la_SOURCES = \
61 plugin_datacache_heap.c
62libgnunet_plugin_datacache_heap_la_LIBADD = \
63 $(top_builddir)/src/statistics/libgnunetstatistics.la \
64 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
65 $(LTLIBINTL)
66libgnunet_plugin_datacache_heap_la_LDFLAGS = \
67 $(GN_PLUGIN_LDFLAGS)
68
59libgnunet_plugin_datacache_mysql_la_SOURCES = \ 69libgnunet_plugin_datacache_mysql_la_SOURCES = \
60 plugin_datacache_mysql.c 70 plugin_datacache_mysql.c
61libgnunet_plugin_datacache_mysql_la_LIBADD = \ 71libgnunet_plugin_datacache_mysql_la_LIBADD = \