aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-06-10 11:18:59 +0000
committerChristian Grothoff <christian@grothoff.org>2012-06-10 11:18:59 +0000
commit5d2bfbd4a69f87c99083fc60954c884af69258f4 (patch)
tree9fb3f83ca4e8f5bc2d8d770086882ff1ab27a56c /src/datastore/Makefile.am
parent00abe8aad5a33c716a02e20cc8257f055edca869 (diff)
downloadgnunet-5d2bfbd4a69f87c99083fc60954c884af69258f4.tar.gz
gnunet-5d2bfbd4a69f87c99083fc60954c884af69258f4.zip
-using testing in datastore tests
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index e9774eddd..cd5b0d481 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -141,18 +141,21 @@ endif
141test_datastore_api_sqlite_SOURCES = \ 141test_datastore_api_sqlite_SOURCES = \
142 test_datastore_api.c 142 test_datastore_api.c
143test_datastore_api_sqlite_LDADD = \ 143test_datastore_api_sqlite_LDADD = \
144 $(top_builddir)/src/testing/libgnunettesting.la \
144 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 145 $(top_builddir)/src/datastore/libgnunetdatastore.la \
145 $(top_builddir)/src/util/libgnunetutil.la 146 $(top_builddir)/src/util/libgnunetutil.la
146 147
147test_datastore_api_management_sqlite_SOURCES = \ 148test_datastore_api_management_sqlite_SOURCES = \
148 test_datastore_api_management.c 149 test_datastore_api_management.c
149test_datastore_api_management_sqlite_LDADD = \ 150test_datastore_api_management_sqlite_LDADD = \
151 $(top_builddir)/src/testing/libgnunettesting.la \
150 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 152 $(top_builddir)/src/datastore/libgnunetdatastore.la \
151 $(top_builddir)/src/util/libgnunetutil.la 153 $(top_builddir)/src/util/libgnunetutil.la
152 154
153perf_datastore_api_sqlite_SOURCES = \ 155perf_datastore_api_sqlite_SOURCES = \
154 perf_datastore_api.c 156 perf_datastore_api.c
155perf_datastore_api_sqlite_LDADD = \ 157perf_datastore_api_sqlite_LDADD = \
158 $(top_builddir)/src/testing/libgnunettesting.la \
156 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 159 $(top_builddir)/src/datastore/libgnunetdatastore.la \
157 $(top_builddir)/src/util/libgnunetutil.la 160 $(top_builddir)/src/util/libgnunetutil.la
158 161
@@ -170,18 +173,21 @@ test_plugin_datastore_sqlite_LDADD = \
170test_datastore_api_mysql_SOURCES = \ 173test_datastore_api_mysql_SOURCES = \
171 test_datastore_api.c 174 test_datastore_api.c
172test_datastore_api_mysql_LDADD = \ 175test_datastore_api_mysql_LDADD = \
176 $(top_builddir)/src/testing/libgnunettesting.la \
173 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 177 $(top_builddir)/src/datastore/libgnunetdatastore.la \
174 $(top_builddir)/src/util/libgnunetutil.la 178 $(top_builddir)/src/util/libgnunetutil.la
175 179
176test_datastore_api_management_mysql_SOURCES = \ 180test_datastore_api_management_mysql_SOURCES = \
177 test_datastore_api_management.c 181 test_datastore_api_management.c
178test_datastore_api_management_mysql_LDADD = \ 182test_datastore_api_management_mysql_LDADD = \
183 $(top_builddir)/src/testing/libgnunettesting.la \
179 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 184 $(top_builddir)/src/datastore/libgnunetdatastore.la \
180 $(top_builddir)/src/util/libgnunetutil.la 185 $(top_builddir)/src/util/libgnunetutil.la
181 186
182perf_datastore_api_mysql_SOURCES = \ 187perf_datastore_api_mysql_SOURCES = \
183 perf_datastore_api.c 188 perf_datastore_api.c
184perf_datastore_api_mysql_LDADD = \ 189perf_datastore_api_mysql_LDADD = \
190 $(top_builddir)/src/testing/libgnunettesting.la \
185 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 191 $(top_builddir)/src/datastore/libgnunetdatastore.la \
186 $(top_builddir)/src/util/libgnunetutil.la 192 $(top_builddir)/src/util/libgnunetutil.la
187 193
@@ -199,18 +205,21 @@ perf_plugin_datastore_mysql_LDADD = \
199test_datastore_api_postgres_SOURCES = \ 205test_datastore_api_postgres_SOURCES = \
200 test_datastore_api.c 206 test_datastore_api.c
201test_datastore_api_postgres_LDADD = \ 207test_datastore_api_postgres_LDADD = \
208 $(top_builddir)/src/testing/libgnunettesting.la \
202 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 209 $(top_builddir)/src/datastore/libgnunetdatastore.la \
203 $(top_builddir)/src/util/libgnunetutil.la 210 $(top_builddir)/src/util/libgnunetutil.la
204 211
205test_datastore_api_management_postgres_SOURCES = \ 212test_datastore_api_management_postgres_SOURCES = \
206 test_datastore_api_management.c 213 test_datastore_api_management.c
207test_datastore_api_management_postgres_LDADD = \ 214test_datastore_api_management_postgres_LDADD = \
215 $(top_builddir)/src/testing/libgnunettesting.la \
208 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 216 $(top_builddir)/src/datastore/libgnunetdatastore.la \
209 $(top_builddir)/src/util/libgnunetutil.la 217 $(top_builddir)/src/util/libgnunetutil.la
210 218
211perf_datastore_api_postgres_SOURCES = \ 219perf_datastore_api_postgres_SOURCES = \
212 perf_datastore_api.c 220 perf_datastore_api.c
213perf_datastore_api_postgres_LDADD = \ 221perf_datastore_api_postgres_LDADD = \
222 $(top_builddir)/src/testing/libgnunettesting.la \
214 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 223 $(top_builddir)/src/datastore/libgnunetdatastore.la \
215 $(top_builddir)/src/util/libgnunetutil.la 224 $(top_builddir)/src/util/libgnunetutil.la
216 225