aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-06-10 10:45:33 +0000
committerChristian Grothoff <christian@grothoff.org>2011-06-10 10:45:33 +0000
commitf7b5b476ba55ee45fefff22777f525cc81b4cae8 (patch)
treea33e5983ab6c8b0e35c1055cb7503ec4fac90041 /src/datastore/Makefile.am
parent0ac9a4984e1e551293ea8ea00f3c8ea2c5460d91 (diff)
downloadgnunet-f7b5b476ba55ee45fefff22777f525cc81b4cae8.tar.gz
gnunet-f7b5b476ba55ee45fefff22777f525cc81b4cae8.zip
adding configure code for --enable-benchmarks, --enable-expensive-tests, some clean up
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am26
1 files changed, 19 insertions, 7 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 4ab887061..a3c484531 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -38,30 +38,42 @@ gnunet_service_datastore_LDADD = \
38 38
39if HAVE_MYSQL 39if HAVE_MYSQL
40 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la 40 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la
41if HAVE_BENCHMARKS
42 MYSQL_BENCHMARKS = \
43 perf_datastore_api_mysql \
44 perf_plugin_datastore_mysql
45endif
41 MYSQL_TESTS = \ 46 MYSQL_TESTS = \
42 test_datastore_api_mysql \ 47 test_datastore_api_mysql \
43 test_datastore_api_management_mysql \ 48 test_datastore_api_management_mysql \
44 test_plugin_datastore_mysql \ 49 test_plugin_datastore_mysql \
45 perf_datastore_api_mysql \ 50 $(MYSQL_BENCHMARKS)
46 perf_plugin_datastore_mysql
47endif 51endif
48if HAVE_SQLITE 52if HAVE_SQLITE
49 SQLITE_PLUGIN = libgnunet_plugin_datastore_sqlite.la 53 SQLITE_PLUGIN = libgnunet_plugin_datastore_sqlite.la
54if HAVE_BENCHMARKS
55 SQLITE_BENCHMARKS = \
56 perf_datastore_api_sqlite \
57 perf_plugin_datastore_sqlite
58endif
50 SQLITE_TESTS = \ 59 SQLITE_TESTS = \
51 test_datastore_api_sqlite \ 60 test_datastore_api_sqlite \
52 test_datastore_api_management_sqlite \ 61 test_datastore_api_management_sqlite \
53 test_plugin_datastore_sqlite \ 62 test_plugin_datastore_sqlite \
54 perf_datastore_api_sqlite \ 63 $(SQLITE_BENCHMARKS)
55 perf_plugin_datastore_sqlite
56endif 64endif
57if HAVE_POSTGRES 65if HAVE_POSTGRES
58 POSTGRES_PLUGIN = libgnunet_plugin_datastore_postgres.la 66 POSTGRES_PLUGIN = libgnunet_plugin_datastore_postgres.la
67if HAVE_BENCHMARKS
68 POSTGRES_BENCHMARKS = \
69 perf_datastore_api_postgres \
70 perf_plugin_datastore_postgres
71endif
59 POSTGRES_TESTS = \ 72 POSTGRES_TESTS = \
60 test_datastore_api_postgres \ 73 test_datastore_api_postgres \
61 test_datastore_api_management_postgres \ 74 test_datastore_api_management_postgres \
62 test_plugin_datastore_postgres \ 75 test_plugin_datastore_postgres \
63 perf_datastore_api_postgres \ 76 $(POSTGRES_BENCHMARKS)
64 perf_plugin_datastore_postgres
65endif 77endif
66 78
67plugin_LTLIBRARIES = \ 79plugin_LTLIBRARIES = \
@@ -113,7 +125,7 @@ check_PROGRAMS = \
113 $(MYSQL_TESTS) \ 125 $(MYSQL_TESTS) \
114 $(POSTGRES_TESTS) 126 $(POSTGRES_TESTS)
115 127
116if !DISABLE_TEST_RUN 128if ENABLE_TEST_RUN
117TESTS = $(check_PROGRAMS) 129TESTS = $(check_PROGRAMS)
118endif 130endif
119 131