aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-11-02 14:10:52 +0000
committerChristian Grothoff <christian@grothoff.org>2012-11-02 14:10:52 +0000
commitb1cd707e422e03960947a6773a6bcb95c0098f2c (patch)
tree7def2c83956758622fec17bb206d479216aee427 /src/dht/Makefile.am
parentc6ef80f13164795b0b53bc7c4c7cae2452cf861e (diff)
downloadgnunet-b1cd707e422e03960947a6773a6bcb95c0098f2c.tar.gz
gnunet-b1cd707e422e03960947a6773a6bcb95c0098f2c.zip
-more DHT test modernization
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am19
1 files changed, 11 insertions, 8 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index 0baf6b00e..2270d094b 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -125,21 +125,21 @@ check_PROGRAMS = \
125 test_dht_twopeer \ 125 test_dht_twopeer \
126 test_dht_multipeer \ 126 test_dht_multipeer \
127 test_dht_line \ 127 test_dht_line \
128 test_dht_2dtorus 128 test_dht_2dtorus \
129# test_dht_monitor 129 test_dht_monitor
130 130
131if HAVE_EXPERIMENTAL 131if HAVE_EXPERIMENTAL
132# These tests still do not work as testbed does 132# These tests still do not work as testbed does
133# not support the respective topology op 133# not support the respective topology op
134 NEW_TESTS = test_dht_2dtorus test_dht_multipeer 134 NEW_TESTS = test_dht_2dtorus test_dht_multipeer
135endif 135endif
136 136
137if ENABLE_TEST_RUN 137if ENABLE_TEST_RUN
138TESTS = test_dht_api $(check_SCRIPTS) \ 138TESTS = test_dht_api $(check_SCRIPTS) \
139 test_dht_twopeer \ 139 test_dht_twopeer \
140 test_dht_line \ 140 test_dht_line \
141 test_dht_monitor \
141 $(NEW_TESTS) 142 $(NEW_TESTS)
142# test_dht_monitor
143endif 143endif
144 144
145test_dht_api_SOURCES = \ 145test_dht_api_SOURCES = \
@@ -184,18 +184,20 @@ test_dht_line_DEPENDENCIES = \
184test_dht_multipeer_SOURCES = \ 184test_dht_multipeer_SOURCES = \
185 test_dht_topo.c 185 test_dht_topo.c
186test_dht_multipeer_LDADD = \ 186test_dht_multipeer_LDADD = \
187 $(top_builddir)/src/dht/libgnunetdhttest.a \
187 $(top_builddir)/src/util/libgnunetutil.la \ 188 $(top_builddir)/src/util/libgnunetutil.la \
188 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 189 $(top_builddir)/src/statistics/libgnunetstatistics.la \
189 $(top_builddir)/src/testing_old/libgnunettesting_old.la \ 190 $(top_builddir)/src/testbed/libgnunettestbed.la \
190 $(top_builddir)/src/dht/libgnunetdht.la 191 $(top_builddir)/src/dht/libgnunetdht.la
191test_dht_multipeer_DEPENDENCIES = \ 192test_dht_multipeer_DEPENDENCIES = \
192 libgnunetdht.la 193 libgnunetdht.la
193 194
194# fixme, rewrite based on test_dht_topo.c! 195test_dht_monitor_SOURCES = \
195test_dht_monitor_SOURCES = test_dht_monitor.c 196 test_dht_monitor.c
196test_dht_monitor_LDADD = \ 197test_dht_monitor_LDADD = \
198 $(top_builddir)/src/dht/libgnunetdhttest.a \
197 $(top_builddir)/src/util/libgnunetutil.la \ 199 $(top_builddir)/src/util/libgnunetutil.la \
198 $(top_builddir)/src/testing_old/libgnunettesting_old.la \ 200 $(top_builddir)/src/testbed/libgnunettestbed.la \
199 $(top_builddir)/src/dht/libgnunetdht.la 201 $(top_builddir)/src/dht/libgnunetdht.la
200test_dht_monitor_DEPENDENCIES = \ 202test_dht_monitor_DEPENDENCIES = \
201 libgnunetdht.la 203 libgnunetdht.la
@@ -205,6 +207,7 @@ EXTRA_DIST = \
205 test_dht_api_data.conf \ 207 test_dht_api_data.conf \
206 test_dht_api_peer1.conf \ 208 test_dht_api_peer1.conf \
207 test_dht_twopeer_data.conf \ 209 test_dht_twopeer_data.conf \
210 test_dht_monitor.conf \
208 test_dht_multipeer.conf \ 211 test_dht_multipeer.conf \
209 test_dht_2dtorus.conf \ 212 test_dht_2dtorus.conf \
210 test_dht_line.conf \ 213 test_dht_line.conf \