aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2014-06-20 14:49:36 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2014-06-20 14:49:36 +0000
commita267473f5f05e8b9e195ed6515f65b7cc49392e2 (patch)
tree081f8ee33343df1af1fb018481b5f47aff17ad91 /src/dht/Makefile.am
parent43e731e418561ac45f923212dd8bba7c8d4a3cb4 (diff)
downloadgnunet-a267473f5f05e8b9e195ed6515f65b7cc49392e2.tar.gz
gnunet-a267473f5f05e8b9e195ed6515f65b7cc49392e2.zip
Add DHT profiler.
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index fd0cf1184..f8918616f 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -55,7 +55,8 @@ libexec_PROGRAMS = \
55noinst_PROGRAMS = \ 55noinst_PROGRAMS = \
56 gnunet-dht-monitor \ 56 gnunet-dht-monitor \
57 gnunet-dht-get \ 57 gnunet-dht-get \
58 gnunet-dht-put 58 gnunet-dht-put \
59 gnunet-dht-profiler
59 60
60gnunet_service_dht_SOURCES = \ 61gnunet_service_dht_SOURCES = \
61 gnunet-service-dht.c gnunet-service-dht.h \ 62 gnunet-service-dht.c gnunet-service-dht.h \
@@ -128,6 +129,16 @@ gnunet_dht_monitor_LDADD = \
128gnunet_dht_monitor_DEPENDENCIES = \ 129gnunet_dht_monitor_DEPENDENCIES = \
129 libgnunetdht.la 130 libgnunetdht.la
130 131
132gnunet_dht_profiler_SOURCES = \
133 gnunet_dht_profiler.c
134gnunet_dht_profiler_LDADD = \
135 $(top_builddir)/src/dht/libgnunetdht.la \
136 $(top_builddir)/src/core/libgnunetcore.la \
137 $(top_builddir)/src/util/libgnunetutil.la \
138 $(top_builddir)/src/testbed/libgnunettestbed.la
139gnunet_dht_profiler_DEPENDENCIES = \
140 libgnunetdht.la
141
131if HAVE_TESTING 142if HAVE_TESTING
132noinst_LIBRARIES = libgnunetdhttest.a 143noinst_LIBRARIES = libgnunetdhttest.a
133endif 144endif