aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-11-02 10:19:00 +0000
committerChristian Grothoff <christian@grothoff.org>2012-11-02 10:19:00 +0000
commitc6ef80f13164795b0b53bc7c4c7cae2452cf861e (patch)
tree9205d3cf10cc02c359b229e291375ca483f93090 /src/dht/Makefile.am
parent2100eaeefbccd6cb2b6f952320092542f82a2051 (diff)
downloadgnunet-c6ef80f13164795b0b53bc7c4c7cae2452cf861e.tar.gz
gnunet-c6ef80f13164795b0b53bc7c4c7cae2452cf861e.zip
-major DHT test cleanup
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am73
1 files changed, 21 insertions, 52 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index 982c33815..0baf6b00e 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -123,27 +123,23 @@ libgnunetdhttest_a_DEPENDENCIES = \
123check_PROGRAMS = \ 123check_PROGRAMS = \
124 test_dht_api \ 124 test_dht_api \
125 test_dht_twopeer \ 125 test_dht_twopeer \
126 test_dht_twopeer_put_get \
127 test_dht_twopeer_get_put \
128 test_dht_twopeer_path_tracking \
129 test_dht_multipeer \ 126 test_dht_multipeer \
130 test_dht_line \ 127 test_dht_line \
131 test_dht_2dtorus \ 128 test_dht_2dtorus
132 test_dht_monitor 129# test_dht_monitor
133 130
134if HAVE_EXPERIMENTAL 131if HAVE_EXPERIMENTAL
135 NEW_TESTS = test_dht_line test_dht_2dtorus 132# These tests still do not work as testbed does
133# not support the respective topology op
134 NEW_TESTS = test_dht_2dtorus test_dht_multipeer
136endif 135endif
137 136
138if ENABLE_TEST_RUN 137if ENABLE_TEST_RUN
139TESTS = test_dht_api $(check_SCRIPTS) \ 138TESTS = test_dht_api $(check_SCRIPTS) \
140 test_dht_twopeer \ 139 test_dht_twopeer \
141 test_dht_twopeer_put_get \ 140 test_dht_line \
142 test_dht_twopeer_get_put \ 141 $(NEW_TESTS)
143 test_dht_twopeer_path_tracking \ 142# test_dht_monitor
144 test_dht_multipeer \
145 $(NEW_TESTS) \
146 test_dht_monitor
147endif 143endif
148 144
149test_dht_api_SOURCES = \ 145test_dht_api_SOURCES = \
@@ -156,9 +152,8 @@ test_dht_api_LDADD = \
156test_dht_api_DEPENDENCIES = \ 152test_dht_api_DEPENDENCIES = \
157 libgnunetdht.la 153 libgnunetdht.la
158 154
159# twopeer is obsolete once new test_dht_topo works...
160test_dht_twopeer_SOURCES = \ 155test_dht_twopeer_SOURCES = \
161 test_dht_twopeer.c 156 test_dht_topo.c
162test_dht_twopeer_LDADD = \ 157test_dht_twopeer_LDADD = \
163 $(top_builddir)/src/util/libgnunetutil.la \ 158 $(top_builddir)/src/util/libgnunetutil.la \
164 $(top_builddir)/src/testing_old/libgnunettesting_old.la \ 159 $(top_builddir)/src/testing_old/libgnunettesting_old.la \
@@ -166,42 +161,6 @@ test_dht_twopeer_LDADD = \
166test_dht_twopeer_DEPENDENCIES = \ 161test_dht_twopeer_DEPENDENCIES = \
167 libgnunetdht.la 162 libgnunetdht.la
168 163
169# twopeer_put_get is obsolete once new test_dht_topo works...
170test_dht_twopeer_put_get_SOURCES = \
171 test_dht_twopeer_put_get.c
172test_dht_twopeer_put_get_LDADD = \
173 $(top_builddir)/src/util/libgnunetutil.la \
174 $(top_builddir)/src/testing_old/libgnunettesting_old.la \
175 $(top_builddir)/src/dht/libgnunetdht.la
176
177# twopeer_get_put is obsolete once new test_dht_topo works...
178test_dht_twopeer_get_put_SOURCES = \
179 test_dht_twopeer_get_put.c
180test_dht_twopeer_get_put_LDADD = \
181 $(top_builddir)/src/util/libgnunetutil.la \
182 $(top_builddir)/src/testing_old/libgnunettesting_old.la \
183 $(top_builddir)/src/dht/libgnunetdht.la
184
185# twopeer_path_tracking is obsolete once new test_dht_topo works...
186test_dht_twopeer_path_tracking_SOURCES = \
187 test_dht_twopeer_path_tracking.c
188test_dht_twopeer_path_tracking_LDADD = \
189 $(top_builddir)/src/util/libgnunetutil.la \
190 $(top_builddir)/src/testing_old/libgnunettesting_old.la \
191 $(top_builddir)/src/dht/libgnunetdht.la
192
193# statistics functions should be integrated with test_dht_topo,
194# then this one also becomes obsolete...
195test_dht_multipeer_SOURCES = \
196 test_dht_multipeer.c
197test_dht_multipeer_LDADD = \
198 $(top_builddir)/src/util/libgnunetutil.la \
199 $(top_builddir)/src/statistics/libgnunetstatistics.la \
200 $(top_builddir)/src/testing_old/libgnunettesting_old.la \
201 $(top_builddir)/src/dht/libgnunetdht.la
202test_dht_multipeer_DEPENDENCIES = \
203 libgnunetdht.la
204
205test_dht_2dtorus_SOURCES = \ 164test_dht_2dtorus_SOURCES = \
206 test_dht_topo.c 165 test_dht_topo.c
207test_dht_2dtorus_LDADD = \ 166test_dht_2dtorus_LDADD = \
@@ -222,6 +181,16 @@ test_dht_line_LDADD = \
222test_dht_line_DEPENDENCIES = \ 181test_dht_line_DEPENDENCIES = \
223 libgnunetdht.la 182 libgnunetdht.la
224 183
184test_dht_multipeer_SOURCES = \
185 test_dht_topo.c
186test_dht_multipeer_LDADD = \
187 $(top_builddir)/src/util/libgnunetutil.la \
188 $(top_builddir)/src/statistics/libgnunetstatistics.la \
189 $(top_builddir)/src/testing_old/libgnunettesting_old.la \
190 $(top_builddir)/src/dht/libgnunetdht.la
191test_dht_multipeer_DEPENDENCIES = \
192 libgnunetdht.la
193
225# fixme, rewrite based on test_dht_topo.c! 194# fixme, rewrite based on test_dht_topo.c!
226test_dht_monitor_SOURCES = test_dht_monitor.c 195test_dht_monitor_SOURCES = test_dht_monitor.c
227test_dht_monitor_LDADD = \ 196test_dht_monitor_LDADD = \
@@ -236,11 +205,11 @@ EXTRA_DIST = \
236 test_dht_api_data.conf \ 205 test_dht_api_data.conf \
237 test_dht_api_peer1.conf \ 206 test_dht_api_peer1.conf \
238 test_dht_twopeer_data.conf \ 207 test_dht_twopeer_data.conf \
239 test_dht_multipeer_data.conf \ 208 test_dht_multipeer.conf \
240 test_dht_2dtorus.conf \ 209 test_dht_2dtorus.conf \
241 test_dht_line.conf \ 210 test_dht_line.conf \
242 test_dht_tools.py.in \ 211 test_dht_tools.py.in \
243 multipeer_topo.dat 212 test_dht_multipeer_topology.dat
244 213
245check_SCRIPTS = \ 214check_SCRIPTS = \
246 test_dht_tools.py 215 test_dht_tools.py