aboutsummaryrefslogtreecommitdiff
path: root/src/dns/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-01-15 20:41:40 +0000
committerChristian Grothoff <christian@grothoff.org>2012-01-15 20:41:40 +0000
commit1574e0f8c2a55363c024a95f440ba7be647efbe1 (patch)
tree5e4507d9aa404ac983c5774b71b25ec6174ee7cc /src/dns/Makefile.am
parent5ec7048ed9ffeddbe06e34a31d388080fae143e5 (diff)
downloadgnunet-1574e0f8c2a55363c024a95f440ba7be647efbe1.tar.gz
gnunet-1574e0f8c2a55363c024a95f440ba7be647efbe1.zip
-removing legacy dns/vpn/exit code and renaming -new versions to current
Diffstat (limited to 'src/dns/Makefile.am')
-rw-r--r--src/dns/Makefile.am47
1 files changed, 11 insertions, 36 deletions
diff --git a/src/dns/Makefile.am b/src/dns/Makefile.am
index 99e78d7d6..f8bdae94e 100644
--- a/src/dns/Makefile.am
+++ b/src/dns/Makefile.am
@@ -16,26 +16,23 @@ pkgcfg_DATA = \
16 dns.conf 16 dns.conf
17 17
18if LINUX 18if LINUX
19HIJACKBIN = gnunet-helper-hijack-dns gnunet-helper-dns 19HIJACKBIN = gnunet-helper-dns
20install-exec-hook: 20install-exec-hook:
21 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-hijack-dns || true
22 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-hijack-dns || true
23 $(SUDO_BINARY) chown root $(bindir)/gnunet-helper-dns || true 21 $(SUDO_BINARY) chown root $(bindir)/gnunet-helper-dns || true
24 $(SUDO_BINARY) chgrp $(GNUNETDNS_GROUP) $(bindir)/gnunet-helper-dns || true 22 $(SUDO_BINARY) chgrp $(GNUNETDNS_GROUP) $(bindir)/gnunet-helper-dns || true
25 $(SUDO_BINARY) chmod 4750 $(bindir)/gnunet-helper-dns || true 23 $(SUDO_BINARY) chmod 4750 $(bindir)/gnunet-helper-dns || true
26 $(SUDO_BINARY) chgrp $(GNUNETDNS_GROUP) $(bindir)/gnunet-service-dns-new || true 24 $(SUDO_BINARY) chgrp $(GNUNETDNS_GROUP) $(bindir)/gnunet-service-dns || true
27 $(SUDO_BINARY) chmod 2755 $(bindir)/gnunet-helper-dns || true 25 $(SUDO_BINARY) chmod 2755 $(bindir)/gnunet-service-dns || true
28else 26else
29install-exec-hook: 27install-exec-hook:
30endif 28endif
31 29
32lib_LTLIBRARIES = \ 30lib_LTLIBRARIES = \
33 libgnunetdnsparser.la \ 31 libgnunetdnsparser.la \
34 libgnunetdnsnew.la \
35 libgnunetdns.la 32 libgnunetdns.la
36 33
37bin_PROGRAMS = \ 34bin_PROGRAMS = \
38 gnunet-service-dns gnunet-service-dns-new $(HIJACKBIN) 35 gnunet-service-dns $(HIJACKBIN)
39 36
40noinst_PROGRAMS = \ 37noinst_PROGRAMS = \
41 gnunet-dns-monitor gnunet-dns-redirector 38 gnunet-dns-monitor gnunet-dns-redirector
@@ -44,50 +41,35 @@ plugin_LTLIBRARIES = \
44 libgnunet_plugin_block_dns.la 41 libgnunet_plugin_block_dns.la
45 42
46 43
47gnunet_helper_hijack_dns_SOURCES = \
48 gnunet-helper-hijack-dns.c
49
50gnunet_helper_dns_SOURCES = \ 44gnunet_helper_dns_SOURCES = \
51 gnunet-helper-dns.c 45 gnunet-helper-dns.c
52 46
53gnunet_service_dns_SOURCES = \
54 gnunet-service-dns.c
55gnunet_service_dns_LDADD = \
56 $(top_builddir)/src/core/libgnunetcore.la \
57 $(top_builddir)/src/statistics/libgnunetstatistics.la \
58 $(top_builddir)/src/util/libgnunetutil.la \
59 $(top_builddir)/src/dht/libgnunetdht.la \
60 $(top_builddir)/src/mesh/libgnunetmesh.la \
61 $(top_builddir)/src/dns/libgnunetdnsparser.la \
62 $(GN_LIBINTL)
63gnunet_service_dns_DEPENDENCIES = \
64 libgnunetdnsparser.la
65 47
66gnunet_dns_monitor_SOURCES = \ 48gnunet_dns_monitor_SOURCES = \
67 gnunet-dns-monitor.c 49 gnunet-dns-monitor.c
68gnunet_dns_monitor_LDADD = \ 50gnunet_dns_monitor_LDADD = \
69 $(top_builddir)/src/dns/libgnunetdnsparser.la \ 51 $(top_builddir)/src/dns/libgnunetdnsparser.la \
70 $(top_builddir)/src/dns/libgnunetdnsnew.la \ 52 $(top_builddir)/src/dns/libgnunetdns.la \
71 $(top_builddir)/src/util/libgnunetutil.la \ 53 $(top_builddir)/src/util/libgnunetutil.la \
72 $(GN_LIBINTL) 54 $(GN_LIBINTL)
73gnunet_dns_monitor_DEPENDENCIES = \ 55gnunet_dns_monitor_DEPENDENCIES = \
74 libgnunetdnsparser.la \ 56 libgnunetdnsparser.la \
75 libgnunetdnsnew.la 57 libgnunetdns.la
76 58
77gnunet_dns_redirector_SOURCES = \ 59gnunet_dns_redirector_SOURCES = \
78 gnunet-dns-redirector.c 60 gnunet-dns-redirector.c
79gnunet_dns_redirector_LDADD = \ 61gnunet_dns_redirector_LDADD = \
80 $(top_builddir)/src/dns/libgnunetdnsparser.la \ 62 $(top_builddir)/src/dns/libgnunetdnsparser.la \
81 $(top_builddir)/src/dns/libgnunetdnsnew.la \ 63 $(top_builddir)/src/dns/libgnunetdns.la \
82 $(top_builddir)/src/util/libgnunetutil.la \ 64 $(top_builddir)/src/util/libgnunetutil.la \
83 $(GN_LIBINTL) 65 $(GN_LIBINTL)
84gnunet_dns_redirector_DEPENDENCIES = \ 66gnunet_dns_redirector_DEPENDENCIES = \
85 libgnunetdnsparser.la \ 67 libgnunetdnsparser.la \
86 libgnunetdnsnew.la 68 libgnunetdns.la
87 69
88gnunet_service_dns_new_SOURCES = \ 70gnunet_service_dns_SOURCES = \
89 gnunet-service-dns_new.c 71 gnunet-service-dns.c
90gnunet_service_dns_new_LDADD = \ 72gnunet_service_dns_LDADD = \
91 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 73 $(top_builddir)/src/statistics/libgnunetstatistics.la \
92 $(top_builddir)/src/util/libgnunetutil.la \ 74 $(top_builddir)/src/util/libgnunetutil.la \
93 $(GN_LIBINTL) 75 $(GN_LIBINTL)
@@ -106,13 +88,6 @@ libgnunetdns_la_LIBADD = \
106libgnunetdns_la_LDFLAGS = \ 88libgnunetdns_la_LDFLAGS = \
107 $(GN_LIB_LDFLAGS) 89 $(GN_LIB_LDFLAGS)
108 90
109libgnunetdnsnew_la_SOURCES = \
110 dns_api_new.c dns_new.h
111libgnunetdnsnew_la_LIBADD = \
112 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
113libgnunetdnsnew_la_LDFLAGS = \
114 $(GN_LIB_LDFLAGS)
115
116libgnunet_plugin_block_dns_la_SOURCES = \ 91libgnunet_plugin_block_dns_la_SOURCES = \
117 plugin_block_dns.c 92 plugin_block_dns.c
118libgnunet_plugin_block_dns_la_LIBADD = \ 93libgnunet_plugin_block_dns_la_LIBADD = \