summaryrefslogtreecommitdiff
path: root/src/dns/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-01-01 23:39:24 +0000
committerChristian Grothoff <christian@grothoff.org>2012-01-01 23:39:24 +0000
commit402a25de1ef93133c9879706071081405ade61f6 (patch)
tree96763797649dd4bff0b7f8b2010a0589f8179dcb /src/dns/Makefile.am
parent3e73780b201b600dd8dd8725f5a628d62d9c4f51 (diff)
downloadgnunet-402a25de1ef93133c9879706071081405ade61f6.tar.gz
gnunet-402a25de1ef93133c9879706071081405ade61f6.zip
first quick hack to extract an initial DNS service API
Diffstat (limited to 'src/dns/Makefile.am')
-rw-r--r--src/dns/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/dns/Makefile.am b/src/dns/Makefile.am
index 4eaade330..9e2566bca 100644
--- a/src/dns/Makefile.am
+++ b/src/dns/Makefile.am
@@ -21,7 +21,9 @@ else
21install-exec-hook: 21install-exec-hook:
22endif 22endif
23 23
24lib_LTLIBRARIES = libgnunetdnsparser.la 24lib_LTLIBRARIES = \
25 libgnunetdnsparser.la \
26 libgnunetdns.la
25 27
26bin_PROGRAMS = \ 28bin_PROGRAMS = \
27 gnunet-service-dns $(HIJACKBIN) 29 gnunet-service-dns $(HIJACKBIN)
@@ -45,4 +47,12 @@ libgnunetdnsparser_la_SOURCES = \
45libgnunetdnsparser_la_LIBADD = \ 47libgnunetdnsparser_la_LIBADD = \
46 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) 48 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
47libgnunetdnsparser_la_LDFLAGS = \ 49libgnunetdnsparser_la_LDFLAGS = \
50 $(GN_LIB_LDFLAGS)
51
52
53libgnunetdns_la_SOURCES = \
54 dns_api.c
55libgnunetdns_la_LIBADD = \
56 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
57libgnunetdns_la_LDFLAGS = \
48 $(GN_LIB_LDFLAGS) \ No newline at end of file 58 $(GN_LIB_LDFLAGS) \ No newline at end of file