aboutsummaryrefslogtreecommitdiff
path: root/src/dns/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-01-01 23:00:59 +0000
committerChristian Grothoff <christian@grothoff.org>2012-01-01 23:00:59 +0000
commit66ffc809472f27d69b9ad7361f8ba29c2674f716 (patch)
tree609623cb79291939f9cb81a8858853a202dae2ca /src/dns/Makefile.am
parent131c43b2b18b12e52ff045e51025706802cbd2e2 (diff)
downloadgnunet-66ffc809472f27d69b9ad7361f8ba29c2674f716.tar.gz
gnunet-66ffc809472f27d69b9ad7361f8ba29c2674f716.zip
-moving DNS code into its own directory
Diffstat (limited to 'src/dns/Makefile.am')
-rw-r--r--src/dns/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/dns/Makefile.am b/src/dns/Makefile.am
new file mode 100644
index 000000000..aad1b0f7a
--- /dev/null
+++ b/src/dns/Makefile.am
@@ -0,0 +1,48 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9endif
10
11pkgcfgdir= $(pkgdatadir)/config.d/
12
13plugindir = $(libdir)/gnunet
14
15if LINUX
16HIJACKBIN = gnunet-helper-hijack-dns
17install-exec-hook:
18 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-hijack-dns || true
19 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-hijack-dns || true
20else
21install-exec-hook:
22endif
23
24lib_LTLIBRARIES = libgnunetdnsparser.la
25
26bin_PROGRAMS = \
27 gnunet-service-dns $(HIJACKBIN)
28
29gnunet_helper_hijack_dns_SOURCES = \
30 gnunet-helper-hijack-dns.c
31
32gnunet_service_dns_SOURCES = \
33 gnunet-service-dns.c gnunet-service-dns-p.h
34gnunet_service_dns_LDADD = \
35 $(top_builddir)/src/core/libgnunetcore.la \
36 $(top_builddir)/src/statistics/libgnunetstatistics.la \
37 $(top_builddir)/src/util/libgnunetutil.la \
38 $(top_builddir)/src/dht/libgnunetdht.la \
39 $(top_builddir)/src/mesh/libgnunetmesh.la \
40 $(GN_LIBINTL) -lgnunetdnsparser
41
42
43libgnunetdnsparser_la_SOURCES = \
44 gnunet-dns-parser.c
45libgnunetdnsparser_la_LIBADD = \
46 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
47libgnunetdnsparser_la_LDFLAGS = \
48 $(GN_LIB_LDFLAGS) \ No newline at end of file