aboutsummaryrefslogtreecommitdiff
path: root/src/dns/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-06-07 11:36:06 +0000
committerChristian Grothoff <christian@grothoff.org>2014-06-07 11:36:06 +0000
commitc2b7de53b4ea53e1c82b529e24ab80d9489743e7 (patch)
tree1f34d751095bca308d1b22e2d6b2ea5df75a2f0d /src/dns/Makefile.am
parent00cad61e45eb0b5ace71795d370b194317c99eee (diff)
downloadgnunet-c2b7de53b4ea53e1c82b529e24ab80d9489743e7.tar.gz
gnunet-c2b7de53b4ea53e1c82b529e24ab80d9489743e7.zip
-testcase and bugfix for hexcoder
Diffstat (limited to 'src/dns/Makefile.am')
-rw-r--r--src/dns/Makefile.am24
1 files changed, 19 insertions, 5 deletions
diff --git a/src/dns/Makefile.am b/src/dns/Makefile.am
index 0ef1623f9..f8645305d 100644
--- a/src/dns/Makefile.am
+++ b/src/dns/Makefile.am
@@ -37,13 +37,16 @@ noinst_PROGRAMS = \
37 gnunet-dns-monitor gnunet-dns-redirector 37 gnunet-dns-monitor gnunet-dns-redirector
38 38
39plugin_LTLIBRARIES = \ 39plugin_LTLIBRARIES = \
40 libgnunet_plugin_block_dns.la 40 libgnunet_plugin_block_dns.la
41 41
42if LINUX 42if LINUX
43check_SCRIPTS = \ 43check_SCRIPTS = \
44 test_gnunet_dns.sh 44 test_gnunet_dns.sh
45endif 45endif
46 46
47check_PROGRAMS = \
48 test_hexcoder
49
47gnunet_helper_dns_SOURCES = \ 50gnunet_helper_dns_SOURCES = \
48 gnunet-helper-dns.c 51 gnunet-helper-dns.c
49 52
@@ -71,7 +74,7 @@ gnunet_dns_redirector_DEPENDENCIES = \
71 libgnunetdns.la 74 libgnunetdns.la
72 75
73gnunet_service_dns_SOURCES = \ 76gnunet_service_dns_SOURCES = \
74 gnunet-service-dns.c 77 gnunet-service-dns.c
75gnunet_service_dns_LDADD = \ 78gnunet_service_dns_LDADD = \
76 $(top_builddir)/src/dns/libgnunetdnsstub.la \ 79 $(top_builddir)/src/dns/libgnunetdnsstub.la \
77 $(top_builddir)/src/tun/libgnunettun.la \ 80 $(top_builddir)/src/tun/libgnunettun.la \
@@ -82,7 +85,7 @@ gnunet_service_dns_DEPENDENCIES = \
82 libgnunetdnsstub.la 85 libgnunetdnsstub.la
83 86
84libgnunetdnsparser_la_SOURCES = \ 87libgnunetdnsparser_la_SOURCES = \
85 dnsparser.c 88 dnsparser.c
86libgnunetdnsparser_la_LIBADD = \ 89libgnunetdnsparser_la_LIBADD = \
87 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \ 90 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
88 -lidn 91 -lidn
@@ -91,7 +94,7 @@ libgnunetdnsparser_la_LDFLAGS = \
91 -version-info 1:0:1 94 -version-info 1:0:1
92 95
93libgnunetdnsstub_la_SOURCES = \ 96libgnunetdnsstub_la_SOURCES = \
94 dnsstub.c 97 dnsstub.c
95libgnunetdnsstub_la_LIBADD = \ 98libgnunetdnsstub_la_LIBADD = \
96 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) 99 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
97libgnunetdnsstub_la_LDFLAGS = \ 100libgnunetdnsstub_la_LDFLAGS = \
@@ -120,4 +123,15 @@ TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
120endif 123endif
121 124
122EXTRA_DIST = \ 125EXTRA_DIST = \
123 $(check_SCRIPTS) 126 $(check_SCRIPTS)
127
128
129test_hexcoder_SOURCES = \
130 test_hexcoder.c
131test_hexcoder_LDADD = \
132 libgnunetdnsparser.la \
133 $(top_builddir)/src/util/libgnunetutil.la
134test_hexcoder_DEPENDENCIES = \
135 libgnunetdnsparser.la \
136 $(top_builddir)/src/util/libgnunetutil.la
137