aboutsummaryrefslogtreecommitdiff
path: root/src/env/Makefile.am
diff options
context:
space:
mode:
authorGabor X Toth <*@tg-x.net>2016-01-12 23:26:47 +0000
committerGabor X Toth <*@tg-x.net>2016-01-12 23:26:47 +0000
commit50eaf8d7de763d25b7dae7ffdee8d7c6b5fe71ea (patch)
treea8023bdb9c9446a45792d7100303265c78713a50 /src/env/Makefile.am
parent3cbdbe18dbd56def00c0014381ff90b4ee664904 (diff)
downloadgnunet-50eaf8d7de763d25b7dae7ffdee8d7c6b5fe71ea.tar.gz
gnunet-50eaf8d7de763d25b7dae7ffdee8d7c6b5fe71ea.zip
psycutil reorg: message, env, slicer
Diffstat (limited to 'src/env/Makefile.am')
-rw-r--r--src/env/Makefile.am43
1 files changed, 0 insertions, 43 deletions
diff --git a/src/env/Makefile.am b/src/env/Makefile.am
deleted file mode 100644
index eda55a8a7..000000000
--- a/src/env/Makefile.am
+++ /dev/null
@@ -1,43 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8if MINGW
9 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
10endif
11
12if USE_COVERAGE
13 AM_CFLAGS = --coverage -O0
14 XLIB = -lgcov
15endif
16
17lib_LTLIBRARIES = libgnunetenv.la
18
19libgnunetenv_la_SOURCES = \
20 env.c
21libgnunetenv_la_LIBADD = \
22 $(top_builddir)/src/util/libgnunetutil.la \
23 $(GN_LIBINTL) $(XLIB)
24libgnunetenv_la_LDFLAGS = \
25 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
26 -version-info 0:0:0
27
28if HAVE_TESTING
29check_PROGRAMS = \
30 test_env
31endif
32
33if ENABLE_TEST_RUN
34AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
35TESTS = $(check_PROGRAMS)
36endif
37
38test_env_SOURCES = \
39 test_env.c
40test_env_LDADD = \
41 libgnunetenv.la \
42 $(top_builddir)/src/testing/libgnunettesting.la \
43 $(top_builddir)/src/util/libgnunetutil.la